aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-12 01:06:23 -0500
committerLeo Famulari <leo@famulari.name>2016-02-12 18:50:32 -0500
commit8ad4ae204f5205c1335cceff22058411a67392eb (patch)
tree45c86d8ac8d88b37c36fca37f0b009e018d5e1c9
parenta14600ecfa6d4304418cda8668dfefdc2c1ce715 (diff)
downloadguix-8ad4ae204f5205c1335cceff22058411a67392eb.tar
guix-8ad4ae204f5205c1335cceff22058411a67392eb.tar.gz
gnu: python-wheel: Define 'python2-variant'.
* gnu/packages/python.scm (python-wheel)[properties]: New field. (python2-wheel): Use 'strip-python2-variant'. (python2-requests): Take the result of 'package-with-python2' directly. * gnu/packages/openstack.scm (python2-requests-mock): Likewise. (python2-oslosphinx): Likewise.
-rw-r--r--gnu/packages/openstack.scm11
-rw-r--r--gnu/packages/python.scm21
2 files changed, 10 insertions, 22 deletions
diff --git a/gnu/packages/openstack.scm b/gnu/packages/openstack.scm
index 9a42a91340..08a76a3695 100644
--- a/gnu/packages/openstack.scm
+++ b/gnu/packages/openstack.scm
@@ -304,12 +304,7 @@ portions of your testing code.")
(license asl2.0)))
(define-public python2-requests-mock
- (let ((requests-mock (package-with-python2 python-requests-mock)))
- (package (inherit requests-mock)
- (propagated-inputs
- `(("python2-requests" ,python2-requests)
- ,@(alist-delete "python-requests"
- (package-propagated-inputs requests-mock)))))))
+ (package-with-python2 python-requests-mock))
(define-public python-stevedore
(package
@@ -601,9 +596,7 @@ from the OpenStack project.")
(license asl2.0)))
(define-public python2-oslosphinx
- (let ((oslosphinx (package-with-python2 python-oslosphinx)))
- (package (inherit oslosphinx)
- (propagated-inputs `(("python2-requests" ,python2-requests))))))
+ (package-with-python2 python-oslosphinx))
(define-public python-oslotest
(package
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f444cdbb64..88c432699b 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2140,16 +2140,16 @@ packages will be properly installed with only the @code{Unpack} step and the
unpacked archive preserves enough information to @code{Spread} (copy data and
scripts to their final locations) at any later time. Wheel files can be
installed with a newer @code{pip} or with wheel's own command line utility.")
- (license license:expat)))
+ (license license:expat)
+ (properties `((python2-variant . ,(delay python2-wheel))))))
(define-public python2-wheel
- (let ((wheel (package-with-python2 python-wheel)))
+ (let ((wheel (package-with-python2
+ (strip-python2-variant python-wheel))))
(package (inherit wheel)
- (native-inputs
- `(("python2-functools32" ,python2-functools32)
- ("python2-jsonschema" ,python2-jsonschema)
- ,@(alist-delete "python-jsonschema"
- (package-native-inputs wheel)))))))
+ (native-inputs `(("python2-functools32" ,python2-functools32)
+ ,@(package-native-inputs wheel))))))
+
(define-public python-requests
(package
@@ -2189,12 +2189,7 @@ than Python’s urllib2 library.")
"0gdr9dxm24amxpbyqpbh3lbwxc2i42hnqv50sigx568qssv3v2ir"))))))
(define-public python2-requests
- (let ((requests (package-with-python2 python-requests)))
- (package (inherit requests)
- (propagated-inputs
- `(("python2-wheel" ,python2-wheel)
- ,@(alist-delete "python-wheel"
- (package-propagated-inputs requests)))))))
+ (package-with-python2 python-requests))
(define-public python-vcversioner
(package