aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAl McElrath <hello@atonesir.com>2016-02-10 13:30:20 -0800
committerLeo Famulari <leo@famulari.name>2016-02-10 17:08:24 -0500
commit8a75c589aacd550eb731474db7756bacf090d2b9 (patch)
treec857e70be347613d6facc79fefb95575c5528079
parentdedb8d5ece44da217452af203c8278d33ecd77eb (diff)
downloadguix-8a75c589aacd550eb731474db7756bacf090d2b9.tar
guix-8a75c589aacd550eb731474db7756bacf090d2b9.tar.gz
gnu: Add notmuch-addrlookup-c.
* gnu/packages/mail.scm (notmuch-addrlookup-c): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/mail.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index d41479e83f..5a9f420b43 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -10,6 +10,7 @@
;;; Copyright © 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2016 Christopher Allan Webber <cwebber@dustycloud.org>
+;;; Copyright © 2016 Al McElrath <hello@yrns.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -414,6 +415,47 @@ attachments, create new maildirs, and so on.")
ing, and tagging large collections of email messages.")
(license gpl3+)))
+(define-public notmuch-addrlookup-c
+ (package
+ (name "notmuch-addrlookup-c")
+ (version "7")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/aperezdc/" name "/archive/v"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0rslg2ifgyhl6asv3yr1f62m9xjfcinv7i6qb07h2k217jqlmrri"))))
+ (build-system gnu-build-system)
+ (arguments
+ '(#:tests? #f ; no tests
+ #:make-flags (list "CC=gcc"
+ (string-append "PREFIX="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (delete 'configure)
+ ;; Remove vim code completion config, it's not needed to
+ ;; build (or be patched).
+ (add-before 'patch-source-shebangs 'delete-ycm-file
+ (lambda _ (delete-file ".ycm_extra_conf.py")))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((bin (string-append
+ (assoc-ref outputs "out") "/bin")))
+ (install-file "notmuch-addrlookup" bin)))))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("glib" ,glib)
+ ("notmuch" ,notmuch)))
+ (home-page "https://github.com/aperezdc/notmuch-addrlookup-c")
+ (synopsis "Address lookup tool for Notmuch")
+ (description "This is an address lookup tool using a Notmuch database,
+useful for email address completion.")
+ (license license:expat)))
+
(define-public python2-notmuch
(package
(name "python2-notmuch")