aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-02-10 21:48:45 -0500
committerLeo Famulari <leo@famulari.name>2016-02-12 18:50:32 -0500
commit519e2f4fde768b0edc16cae75faea55abefa39eb (patch)
treeab0e7b0642a028a37f2601ee5739e5b9203ff751
parent50fe318c3c5004210b89fe4f82ca5183c557e1fa (diff)
downloadguix-519e2f4fde768b0edc16cae75faea55abefa39eb.tar
guix-519e2f4fde768b0edc16cae75faea55abefa39eb.tar.gz
gnu: python-cryptography: Define 'python2-variant'.
* gnu/packages/python.scm (python-cryptography)[properties]: New field. (python2-cryptography): Use 'strip-python2-variant'. (python2-pyopenssl): Take the result of 'package-with-python2' directly.
-rw-r--r--gnu/packages/python.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 3758eed3a3..fc8582f2f4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -5816,10 +5816,12 @@ libraryā€¯ for Python. The package includes both high level recipes, and low
level interfaces to common cryptographic algorithms such as symmetric ciphers,
message digests and key derivation functions.")
;; Distributed under either BSD-3 or ASL2.0
- (license (list bsd-3 asl2.0))))
+ (license (list bsd-3 asl2.0))
+ (properties `((python2-variant . ,(delay python2-cryptography))))))
(define-public python2-cryptography
- (let ((crypto (package-with-python2 python-cryptography)))
+ (let ((crypto (package-with-python2
+ (strip-python2-variant python-cryptography))))
(package (inherit crypto)
(propagated-inputs
`(("python2-ipaddress" ,python2-ipaddress)
@@ -5876,12 +5878,7 @@ library.")
(license asl2.0)))
(define-public python2-pyopenssl
- (let ((pyopenssl (package-with-python2 python-pyopenssl)))
- (package (inherit pyopenssl)
- (propagated-inputs
- `(("python2-cryptography" ,python2-cryptography)
- ,@(alist-delete "python-cryptography"
- (package-propagated-inputs pyopenssl)))))))
+ (package-with-python2 python-pyopenssl))
(define-public python-pip
(package