aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Nieuwenhuizen <janneke@gnu.org>2016-02-09 20:44:59 +0100
committerLeo Famulari <leo@famulari.name>2016-02-12 18:01:05 -0500
commit50fe318c3c5004210b89fe4f82ca5183c557e1fa (patch)
tree3bb30ce406d842af9cb9545b8cf25849a6b0db80
parente4c38581f3b922ba80df58144d7638251bee311f (diff)
downloadguix-50fe318c3c5004210b89fe4f82ca5183c557e1fa.tar
guix-50fe318c3c5004210b89fe4f82ca5183c557e1fa.tar.gz
gnu: Add tcllib.
* gnu/packages/tcl.scm (tcllib): New variable. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/tcl.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/tcl.scm b/gnu/packages/tcl.scm
index ff487a84dd..d98d2d619a 100644
--- a/gnu/packages/tcl.scm
+++ b/gnu/packages/tcl.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Jan Nieuwenhuizen <janneke@gnu.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -218,3 +219,28 @@ interfaces (GUIs) in the Tcl language.")
;; pTk/license.terms, pTk/license.html_lib, and pTk/Tix.license for
;; details of this license."
(license (package-license perl))))
+
+(define-public tcllib
+ (package
+ (name "tcllib")
+ (version "1.18")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://sourceforge/" name "/"
+ name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "05dmrk9qsryah2n17z6z85dj9l9lfyvnsd7faw0p9bs1pp5pwrkj"))))
+ (build-system gnu-build-system)
+ (native-inputs
+ `(("tcl" ,tcl)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "TCLLIBPATH")
+ (separator " ")
+ (files (list (string-append "lib/tcllib" version))))))
+ (home-page "https://core.tcl.tk/tcllib/home")
+ (synopsis "Standard Tcl Library")
+ (description "Tcllib, the standard Tcl library, is a collection of common
+utility functions and modules all written in high-level Tcl.")
+ (license (package-license tcl))))