aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNi* Gillmann <ng@niasterisk.space>2016-01-13 18:36:31 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-02-12 10:17:05 +0100
commit3ccdd4305ef76e7c5c10554a9d1c338c3362078f (patch)
tree950c0c5e04b2078ffc6f920cb70b1011a7bebcb7
parent1eb6bbd8c0efee73b4253d3661b096da0e0cdd91 (diff)
downloadguix-3ccdd4305ef76e7c5c10554a9d1c338c3362078f.tar
guix-3ccdd4305ef76e7c5c10554a9d1c338c3362078f.tar.gz
gnu: Add gnunet-gtk.
* gnu/packages/gnunet.scm (gnunet-gtk): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/gnunet.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/gnunet.scm b/gnu/packages/gnunet.scm
index 0b55c1ad30..7a7ade02f4 100644
--- a/gnu/packages/gnunet.scm
+++ b/gnu/packages/gnunet.scm
@@ -3,6 +3,8 @@
;;; Copyright © 2014 Sree Harsha Totakura <sreeharsha@totakura.in>
;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2015 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016 Ni* Gillmann <ng@niasterisk.space>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -22,14 +24,17 @@
(define-module (gnu packages gnunet)
#:use-module (gnu packages)
#:use-module (gnu packages file)
+ #:use-module (gnu packages aidc)
#:use-module (gnu packages autotools)
#:use-module (gnu packages compression)
#:use-module (gnu packages curl)
#:use-module (gnu packages geeqie)
#:use-module (gnu packages gettext)
#:use-module (gnu packages glib)
+ #:use-module (gnu packages gnome)
#:use-module (gnu packages gnupg)
#:use-module (gnu packages groff)
+ #:use-module (gnu packages gtk)
#:use-module (gnu packages guile)
#:use-module (gnu packages gstreamer)
#:use-module (gnu packages libidn)
@@ -288,3 +293,33 @@ GNUnet services, including the @dfn{identity} and @dfn{file sharing}
services.")
(home-page "http://gnu.org/software/guix")
(license license:gpl3+))))
+
+;; FIXME: "gnunet-setup" segfaults under certain conditions and "gnunet-gtk"
+;; does not seem to be fully functional. This has been reported upstream:
+;; http://lists.gnu.org/archive/html/gnunet-developers/2016-02/msg00004.html
+(define-public gnunet-gtk
+ (package (inherit gnunet)
+ (name "gnunet-gtk")
+ (version (package-version gnunet))
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "mirror://gnu/gnunet/gnunet-gtk-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1p38k1s6a2fmcfc9a7cf1zrdycm9h06kqdyand4s3k500nj6mb4g"))))
+ (arguments
+ `(#:configure-flags
+ (list "--without-libunique"
+ "--with-qrencode")))
+ (inputs
+ `(("gnunet" ,gnunet)
+ ("libgcrypt" ,libgcrypt)
+ ("gtk+" ,gtk+)
+ ("libextractor" ,libextractor)
+ ("glade3" ,glade3)
+ ("qrencode" ,qrencode)))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("libglade" ,libglade)))
+ (synopsis "Graphical front-end tools for GNUnet")))