aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-04-19 02:29:43 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-04-19 02:29:43 +0200
commitf32164abd3d9c307959cf60393cdc9027b8703ca (patch)
tree56c436312e47be688f6c69ba84f01d2d30b04c44
parent20b3fde7763a14f605ac8a0aba1abfa73a6e7dda (diff)
downloadguix-f32164abd3d9c307959cf60393cdc9027b8703ca.tar
guix-f32164abd3d9c307959cf60393cdc9027b8703ca.tar.gz
gnu: python2-send2trash: Don't inherit properties from python-send2trash.
This is a follow-up to commit 20b3fde7763a14f605ac8a0aba1abfa73a6e7dda. Commits and beer do not mix well. * gnu/packages/python-xyz.scm (python2-send2trash): Inherit using STRIP-PYTHON2-VARIANT.
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index f64a09e9b3..9d661411c4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13586,7 +13586,7 @@ user's @file{~/Trash} directory.")
(define-public python2-send2trash
(package
- (inherit (package-with-python2 python-send2trash))
+ (inherit (package-with-python2 (strip-python2-variant python-send2trash)))
(arguments
(substitute-keyword-arguments (package-arguments python-send2trash)
((#:phases phases)