aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authormikadoZero <mikadozero@yandex.com>2019-03-25 19:39:09 -0400
committerLudovic Courtès <ludo@gnu.org>2019-04-16 19:09:55 +0200
commitcfcec4abf61c5f23b4fe125a8c354d6dfa32c2ba (patch)
treee549b12d7617649755dc67965365cc5e3c911278
parent90b94761b673665e212e2677e5ed9924f9a6af42 (diff)
downloadguix-cfcec4abf61c5f23b4fe125a8c354d6dfa32c2ba.tar
guix-cfcec4abf61c5f23b4fe125a8c354d6dfa32c2ba.tar.gz
gnu: Add emacs-ace-link.
* gnu/packages/emacs-xyz.scm (emacs-ace-link): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/emacs-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9d69938683..7aec695205 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -44,6 +44,7 @@
;;; Copyright © 2018, 2019 Brett Gilio <brettg@posteo.net>
;;; Copyright © 2019 Dimakakos Dimos <bendersteed@teknik.io>
;;; Copyright © 2019 Brian Leung <bkleung89@gmail.com>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1140,6 +1141,34 @@ within a specified width. It is useful for displaying long track titles.")
;;; Miscellaneous.
;;;
+(define-public emacs-ace-link
+ (package
+ (name "emacs-ace-link")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/abo-abo/ace-link.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "147dz79vg4ym5wg3d544bw2khdb2j3hr73rw4qfm64wf0q2dj0vk"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-avy" ,emacs-avy)))
+ (home-page "https://github.com/abo-abo/ace-link")
+ (synopsis "Quickly follow links in Emacs")
+ (description
+ "Currently, to jump to a link in a @code{Info-mode}, @code{help-mode},
+@code{woman-mode}, @code{org-mode}, @code{eww-mode}, @code{compilation-mode},
+@code{goto-address-mode} buffer, you can tab through the links to select the
+one you want. This is an O(N) operation, where the N is the amount of links.
+This package turns this into an O(1) operation. It does so by assigning a
+letter to each link using avy.")
+ (license license:gpl3+)))
+
(define-public emacs-bbdb
(package
(name "emacs-bbdb")