aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-16 21:05:56 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-16 22:31:28 +0200
commitbaa787745c430317fe40f074b48e9951a6b34fa4 (patch)
treee1b033a3e206455fcd3e9af54d55528bfe33f90c
parentfbd2a245f7c6caaa231658300fa2eaf7beca1e32 (diff)
downloadguix-baa787745c430317fe40f074b48e9951a6b34fa4.tar
guix-baa787745c430317fe40f074b48e9951a6b34fa4.tar.gz
gnu: Add lucene++.
* gnu/packages/rdf.scm (lucene++): New variable.
-rw-r--r--gnu/packages/rdf.scm34
1 files changed, 33 insertions, 1 deletions
diff --git a/gnu/packages/rdf.scm b/gnu/packages/rdf.scm
index 4a3efd8d3f..3e2db7acdf 100644
--- a/gnu/packages/rdf.scm
+++ b/gnu/packages/rdf.scm
@@ -2,6 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2015, 2016, 2018 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2019 Julien Lepiller <julien@lepiller.eu>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -20,7 +21,7 @@
(define-module (gnu packages rdf)
#:use-module ((guix licenses)
- #:select (non-copyleft isc gpl2 lgpl2.1 lgpl2.1+))
+ #:select (non-copyleft asl2.0 isc gpl2 lgpl2.1 lgpl2.1+ lgpl3+))
#:use-module (guix packages)
#:use-module (guix git-download)
#:use-module (guix download)
@@ -119,6 +120,37 @@ full-featured indexing and searching API. It is a port of the very popular
Java Lucene text search engine API to C++.")
(license lgpl2.1)))
+(define-public lucene++
+ (package
+ (name "lucene++")
+ (version "3.0.7")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/luceneplusplus/LucenePlusPlus")
+ (commit (string-append "rel_" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "06b37fly6l27zc6kbm93f6khfsv61w792j8xihfagpcm9cfz2zi1"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:configure-flags
+ ;; CXX_FLAGS suggested in a closed issue on github:
+ ;; https://github.com/luceneplusplus/LucenePlusPlus/issues/100
+ (list "-Wno-dev" "-DCMAKE_CXX_FLAGS=-DBOOST_VARIANT_USE_RELAXED_GET_BY_DEFAULT"
+ ;; Install in lib64 break rpath
+ "-DCMAKE_INSTALL_LIBDIR:PATH=lib")))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("boost" ,boost)))
+ (home-page "https://github.com/luceneplusplus/LucenePlusPlus")
+ (synopsis "Text search engine")
+ (description "Lucene++ is an up to date C++ port of the popular Java
+Lucene library, a high-performance, full-featured text search engine.")
+ (license (list asl2.0 lgpl3+)))); either asl or lgpl.
+
(define-public lrdf
(package
(name "lrdf")