aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2019-04-19 15:10:58 -0400
committerLeo Famulari <leo@famulari.name>2019-04-19 15:14:54 -0400
commit1e72a23d498c137f99b21ae05b5e559c07e22bc6 (patch)
tree5b7cde1392fc3161fb28b8b2530e1715ee7764f7
parent18f8770d58c824448f9a3c3a48bfcee1fe8b2a91 (diff)
downloadguix-1e72a23d498c137f99b21ae05b5e559c07e22bc6.tar
guix-1e72a23d498c137f99b21ae05b5e559c07e22bc6.tar.gz
gnu: rct: Be more idiomatic.
* gnu/packages/cpp.scm (rct): Move the call to 'git-version' into the package definition. [source]: Explicitly include the source URI rather than using 'home-page'.
-rw-r--r--gnu/packages/cpp.scm9
1 files changed, 4 insertions, 5 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 4e8f12248f..e0af0dd1a9 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -72,16 +72,14 @@ operating system functions.")
(define-public rct
(let* ((commit "b3e6f41d9844ef64420e628e0c65ed98278a843a")
- (revision "2")
- (version (git-version "0.0.0" revision commit)))
+ (revision "2"))
(package
(name "rct")
- (version version)
- (home-page "https://github.com/Andersbakken/rct")
+ (version (git-version "0.0.0" revision commit))
(source (origin
(method git-fetch)
(uri (git-reference
- (url home-page)
+ (url "https://github.com/Andersbakken/rct")
(commit commit)))
(sha256
(base32
@@ -99,6 +97,7 @@ operating system functions.")
(inputs
`(("openssl" ,openssl)
("zlib" ,zlib)))
+ (home-page "https://github.com/Andersbakken/rct")
(synopsis "C++ library providing Qt-like APIs on top of the STL")
(description "Rct is a set of C++ tools that provide nicer (more Qt-like)
APIs on top of Standard Template Library (@dfn{STL}) classes.")