aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-17 00:42:16 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-17 03:23:37 +0200
commit067826abe37fd087681da4ed906d398977a14847 (patch)
tree4282f856aac91eb3f8a128364336a043e538b885
parent564df7e58427248f4678d02d720286d0a0538d0d (diff)
downloadguix-067826abe37fd087681da4ed906d398977a14847.tar
guix-067826abe37fd087681da4ed906d398977a14847.tar.gz
gnu: the-legend-of-edgar: Update to 1.31.
* gnu/packages/games.scm (the-legend-of-edgar): Update to 1.31. [inputs]: Use SDL 2 union. [arguments]: Adjust accordingly.
-rw-r--r--gnu/packages/games.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index c7bd35fbff..d22d8ba7a4 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -6485,7 +6485,7 @@ the desired spell.")
(define-public the-legend-of-edgar
(package
(name "the-legend-of-edgar")
- (version "1.30")
+ (version "1.31")
(source
(origin
(method url-fetch)
@@ -6493,10 +6493,9 @@ the desired spell.")
(string-append "https://github.com/riksweeney/edgar/releases/download/"
version "/edgar-" version "-1.tar.gz"))
(sha256
- (base32
- "0bhbs33dg0nb8wqlh6px1jj41j05f89ngdqwdkffabmjk7wq5isx"))))
+ (base32 "0i4851ci8a86ql4bhdq3xdfmf4b9z5zrd4xpc6vhi06697zgm13i"))))
(build-system gnu-build-system)
- (arguments '(#:tests? #f ; there are no tests
+ (arguments '(#:tests? #f ; there are no tests
#:make-flags
(list "CC=gcc"
(string-append "PREFIX=" (assoc-ref %outputs "out"))
@@ -6506,14 +6505,13 @@ the desired spell.")
(delete 'configure)
(add-before 'build 'fix-env
(lambda* (#:key inputs #:allow-other-keys)
- (setenv "CPATH" (string-append (assoc-ref inputs "sdl")
- "/include/SDL/"))
+ (setenv "CPATH"
+ (string-append (assoc-ref inputs "sdl2-union")
+ "/include/SDL2"))
#t)))))
- (inputs `(("sdl" ,sdl)
- ("sdl-img" ,sdl-image)
- ("sdl-mixer" ,sdl-mixer)
- ("sdl-ttf" ,sdl-ttf)
- ("zlib" ,zlib)))
+ (inputs
+ `(("sdl2-union" ,(sdl-union (list sdl2 sdl2-image sdl2-mixer sdl2-ttf)))
+ ("zlib" ,zlib)))
(native-inputs
`(("pkg-config" ,pkg-config)
("autoconf" ,autoconf)