aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTonton <tonton@riseup.net>2018-05-11 22:29:32 +0200
committerLudovic Courtès <ludo@gnu.org>2018-05-13 23:16:16 +0200
commit44cea5784128353f0449899ae4ca7fdb5259c024 (patch)
tree72cd6bf782393220032193b720734b80a3d89838
parent68fdb38f542d66d329778582c28bf7fad24324a9 (diff)
downloadguix-44cea5784128353f0449899ae4ca7fdb5259c024.tar
guix-44cea5784128353f0449899ae4ca7fdb5259c024.tar.gz
gnu: Add ghc-quickcheck-2.9.
* gnu/packages/haskell-check.scm (ghc-quickcheck-2.9): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/haskell-check.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/haskell-check.scm b/gnu/packages/haskell-check.scm
index 6b1d769313..7453f9fbf1 100644
--- a/gnu/packages/haskell-check.scm
+++ b/gnu/packages/haskell-check.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2017 Danny Milosavljevic <dannym@scratchpost.org>
;;; Copyright © 2017 rsiddharth <s@ricketyspace.net>
;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Tonton <tonton@riseup.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -451,6 +452,19 @@ hold in a large number of randomly generated cases. Specifications are
expressed in Haskell, using combinators defined in the QuickCheck library.")
(license license:bsd-3)))
+(define-public ghc-quickcheck-2.9
+ (package
+ (inherit ghc-quickcheck)
+ (name "ghc-quickcheck")
+ (version "2.9.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/QuickCheck-2.9.2/QuickCheck-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "119np67qvx8hyp9vkg4gr2wv3lj3j6ay2vl4hxspkg43ymb1cp0m"))))))
+
(define-public ghc-quickcheck-latest
(package (inherit ghc-quickcheck)
(version "2.11.3")