aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhu Zihao <all_but_last@163.com>2022-01-12 00:42:32 +0800
committerOleg Pykhalov <go.wigust@gmail.com>2022-01-21 16:45:33 +0300
commitfb81687228dee977825ce62cc1c22a6ad75d7e77 (patch)
tree572ed1969276f5d88c3f389c7f2e14836e83b97d
parent8ed6a8884c2e6deab80da6e416b991afbc58df35 (diff)
downloadguix-fb81687228dee977825ce62cc1c22a6ad75d7e77.tar
guix-fb81687228dee977825ce62cc1c22a6ad75d7e77.tar.gz
gnu: nix: Use G-expression.
* gnu/packages/package-management.scm (nix)[arguments]: Convert to G-expression. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
-rw-r--r--gnu/packages/package-management.scm26
1 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index c9c6ec7ef2..4c75eb285d 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -676,19 +676,19 @@ GTK icon cache for instance.")))
(search-patches "nix-dont-build-html-doc.diff"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags '("--sysconfdir=/etc" "--enable-gc")
- #:phases
- (modify-phases %standard-phases
- (replace 'install
- ;; Don't try & fail to create subdirectories in /etc, but keep them
- ;; in the output as examples.
- (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (etc (string-append out "/etc")))
- (apply invoke "make" "install"
- (string-append "sysconfdir=" etc)
- (string-append "profiledir=" etc "/profile.d")
- make-flags)))))))
+ (list
+ #:configure-flags #~(list "--sysconfdir=/etc" "--enable-gc")
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'install
+ ;; Don't try & fail to create subdirectories in /etc, but keep them
+ ;; in the output as examples.
+ (lambda* (#:key (make-flags '()) outputs #:allow-other-keys)
+ (let ((etc (string-append #$output "/etc")))
+ (apply invoke "make" "install"
+ (string-append "sysconfdir=" etc)
+ (string-append "profiledir=" etc "/profile.d")
+ make-flags)))))))
(native-inputs
(list autoconf
autoconf-archive