aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorzimoun <zimon.toutoune@gmail.com>2022-01-18 18:54:14 +0100
committerRicardo Wurmus <rekado@elephly.net>2022-01-21 15:53:17 +0100
commitb8c103a2a50360f04ab4397f6219f778bfcd71d0 (patch)
tree98a9f5d6a43f1faceff82ff53a4c9af2389adb73
parentce585ae2a3a26683746adecf0d0f8f6952e8ecfe (diff)
downloadguix-b8c103a2a50360f04ab4397f6219f778bfcd71d0.tar
guix-b8c103a2a50360f04ab4397f6219f778bfcd71d0.tar.gz
gnu: Add r-scico.
* gnu/packages/cran.scm (r-scico): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 25 insertions, 1 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index ce7655e6a6..2caa12031b 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -31,7 +31,7 @@
;;; Copyright © 2020 Antoine Côté <antoine.cote@posteo.net>
;;; Copyright © 2020 Arun Isaac <arunisaac@systemreboot.net>
;;; Copyright © 2020 Magali Lemes <magalilemes00@gmail.com>
-;;; Copyright © 2020, 2021 Simon Tournier <zimon.toutoune@gmail.com>
+;;; Copyright © 2020, 2021, 2022 Simon Tournier <zimon.toutoune@gmail.com>
;;; Copyright © 2020 Aniket Patil <aniket112.patil@gmail.com>
;;; Copyright © 2021 Marcel Schilling <marcel.schilling@uni-luebeck.de>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
@@ -27108,6 +27108,30 @@ used in further calculations that rely on a specific temporal spacing between
observations.")
(license license:expat)))
+(define-public r-scico
+ (package
+ (name "r-scico")
+ (version "1.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "scico" version))
+ (sha256
+ (base32 "08grfbjd5s0vdw76ni37yjl2242rr8i2jy72sgpwgra282hpnji3"))))
+ (properties `((upstream-name . "scico")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-scales))
+ (home-page "https://github.com/thomasp85/scico")
+ (synopsis "Colour Palettes Based on the Scientific Colour-Maps")
+ (description
+ "This package provides colour choice in information visualisation. It
+important in order to avoid being mislead by inherent bias in the used colour
+palette. This package provides access to the perceptually uniform and
+colour-blindness friendly palettes developed by Fabio Crameri and released
+under the \"Scientific Colour-Maps\" moniker. The package contains 24
+different palettes and includes both diverging and sequential types.")
+ (license license:expat)))
+
(define-public r-slider
(package
(name "r-slider")