aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2018-10-07 15:08:46 -0400
committerLeo Famulari <leo@famulari.name>2018-10-07 15:27:20 -0400
commitcd220e60da3add3884aef7cc0ab8f4b9e8fb2e3c (patch)
tree3c2ae2c04b9d5d60df97fb8cd38c3b375912c4af
parent247537da81095d3bc03dc210954910d1008bafd3 (diff)
downloadguix-cd220e60da3add3884aef7cc0ab8f4b9e8fb2e3c.tar
guix-cd220e60da3add3884aef7cc0ab8f4b9e8fb2e3c.tar.gz
gnu: ncmpc: Update to 0.32.
* gnu/packages/mpd.scm (ncmpc): Update to 0.32. [inputs]: Add boost, pcre, and python-sphinx. Remove glib. [arguments]: Install the man pages correctly. Remove unnecessary configure flag.
-rw-r--r--gnu/packages/mpd.scm16
1 files changed, 11 insertions, 5 deletions
diff --git a/gnu/packages/mpd.scm b/gnu/packages/mpd.scm
index c024152dda..3e69ddba69 100644
--- a/gnu/packages/mpd.scm
+++ b/gnu/packages/mpd.scm
@@ -47,6 +47,7 @@
#:use-module (gnu packages linux)
#:use-module (gnu packages mp3)
#:use-module (gnu packages ncurses)
+ #:use-module (gnu packages pcre)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
#:use-module (gnu packages pulseaudio)
@@ -186,7 +187,7 @@ player daemon.")
(define-public ncmpc
(package
(name "ncmpc")
- (version "0.30")
+ (version "0.32")
(source (origin
(method url-fetch)
(uri
@@ -195,11 +196,14 @@ player daemon.")
"/ncmpc-" version ".tar.xz"))
(sha256
(base32
- "18qj3cgqczgfk334x0ywxwa1ckrk9fbjyp34n4zzcxwaifshrzp3"))))
+ "1b01q1pcaw5yyhvmlffc3h0r3w8qy7rhn55a7xj4qkcfqvs8ap08"))))
(build-system meson-build-system)
(arguments
`(#:configure-flags
- (list "-Dcurses=ncurses")
+ ;; Otherwise, they are installed incorrectly, in
+ ;; '$out/share/man/man/man1'.
+ (list (string-append "-Dmandir=" (assoc-ref %outputs "out")
+ "/share"))
#:phases
(modify-phases %standard-phases
(add-before 'configure 'expand-C++-include-path
@@ -211,11 +215,13 @@ player daemon.")
(setenv path (string-append c++ ":" (getenv path)))
#t))))))
(inputs `(("gcc", gcc-8) ; for its C++14 support
- ("glib" ,glib)
+ ("boost" ,boost)
+ ("pcre" ,pcre)
("libmpdclient" ,libmpdclient)
("ncurses" ,ncurses)))
(native-inputs `(("gettext" ,gettext-minimal) ; for xgettext
- ("pkg-config" ,pkg-config)))
+ ("pkg-config" ,pkg-config)
+ ("python-sphinx" ,python-sphinx)))
(synopsis "Curses Music Player Daemon client")
(description "ncmpc is a fully featured MPD client, which runs in a
terminal using ncurses.")