aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-10-07 14:14:13 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-10-07 14:14:13 +0200
commit2c4be1add077bf30f949282edcc2ea507ba44497 (patch)
treef6d74a9dcc429e9af85151edece7d7a67965239c
parentc8a99ab9112b6a671b15766301f03e428108c4eb (diff)
downloadguix-2c4be1add077bf30f949282edcc2ea507ba44497.tar
guix-2c4be1add077bf30f949282edcc2ea507ba44497.tar.gz
gnu: Add java-w3c-smil.
* gnu/packages/batik.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/batik.scm90
2 files changed, 91 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 8f854e98b5..f1ce800dd5 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -77,6 +77,7 @@ GNU_SYSTEM_MODULES = \
%D%/packages/backup.scm \
%D%/packages/base.scm \
%D%/packages/bash.scm \
+ %D%/packages/batik.scm \
%D%/packages/bdw-gc.scm \
%D%/packages/benchmark.scm \
%D%/packages/bioconductor.scm \
diff --git a/gnu/packages/batik.scm b/gnu/packages/batik.scm
new file mode 100644
index 0000000000..91eb8f01d5
--- /dev/null
+++ b/gnu/packages/batik.scm
@@ -0,0 +1,90 @@
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2018 Danny Milosavljevic <dannym@scratchpost.org>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages batik)
+ #:use-module ((guix licenses) #:prefix license:)
+ #:use-module (guix utils)
+ #:use-module (guix download)
+ #:use-module (guix git-download)
+ #:use-module (guix packages)
+ #:use-module (guix build-system ant)
+ #:use-module (gnu packages)
+ #:use-module (gnu packages compression)
+ #:use-module (gnu packages java)
+ #:use-module (gnu packages textutils))
+
+(define-public java-w3c-smil-3.0
+ (package
+ (name "java-w3c-smil")
+ (version "3.0")
+ (source #f)
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "w3c-smil.jar"
+ #:source-dir "."
+ #:tests? #f ; No tests exist.
+ #:phases
+ (modify-phases %standard-phases
+ (replace 'unpack
+ (lambda* (#:key source #:allow-other-keys)
+ ;; https://www.w3.org/TR/SMIL3/smil-timing.html#q142
+ (mkdir-p "org/w3c/dom/smil")
+ (call-with-output-file "org/w3c/dom/smil/ElementTimeControl.java"
+ (lambda (port)
+ (format port "
+package org.w3c.dom.smil;
+
+import org.w3c.dom.DOMException;
+
+public interface ElementTimeControl {
+ public boolean beginElement();
+
+ public boolean beginElementAt(float offset);
+
+ public boolean endElement();
+
+ public boolean endElementAt(float offset);
+}
+")))
+ (call-with-output-file "org/w3c/dom/smil/TimeEvent.java"
+ (lambda (port)
+ (format port "
+package org.w3c.dom.smil;
+
+import org.w3c.dom.events.Event;
+import org.w3c.dom.views.AbstractView;
+
+public interface TimeEvent extends Event {
+ public AbstractView getView();
+
+ public int getDetail();
+
+ public void initTimeEvent(String typeArg,
+ AbstractView viewArg,
+ int detailArg);
+
+}
+")))
+ #t)))))
+ (native-inputs
+ `(("unzip" ,unzip)))
+ (home-page "https://www.w3.org/Style/CSS/SAC/")
+ (synopsis "W3C SAC interface for CSS parsers in Java")
+ (description "This package provides a SAC interface by the W3C.
+SAC is an interface for CSS parsers.")
+ (license license:w3c)))