aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2018-10-08 17:29:34 +0200
committerLudovic Courtès <ludo@gnu.org>2018-10-08 18:32:42 +0200
commit1d6417340d6c6a80e24b9cd7e9c357b87c8da309 (patch)
tree1dde7ddbefb82f29fac43a3c6ae8a2940dade015
parentf6e9976393c80d12b5f3235bf7fe593077cbc9d1 (diff)
downloadguix-1d6417340d6c6a80e24b9cd7e9c357b87c8da309.tar
guix-1d6417340d6c6a80e24b9cd7e9c357b87c8da309.tar.gz
gnu: Add font-sil-gentium.
* gnu/packages/fonts.scm (font-sil-gentium): New variable.
-rw-r--r--gnu/packages/fonts.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 6d4abc637b..7fdcda4eee 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -1302,3 +1302,29 @@ Kannada, Malayalam, Manipuri, Oriya, Punjabi, Tamil and Telugu scripts.")
"Inria Sans and Inria Serif are the two members of a type family designed
for Inria, a public research institute in computer science and mathematics.")
(license license:silofl1.1)))
+
+(define-public font-sil-gentium
+ (package
+ (name "font-sil-gentium")
+ (version "5.000")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://software.sil.org/downloads/r/gentium/GentiumPlus-"
+ version ".zip"))
+ (sha256
+ (base32
+ "0m7189870hha217n1vgpmf89mwggrxkh679ffi1lxpnjggqi2n9k"))))
+ ;; Note: The zip file provides TTF files only, but the developer release,
+ ;; which contains additional files, has a 'SOURCES.txt' file that says
+ ;; that "the primary source files for the fonts are the fonts themselves".
+ ;; Thus it looks like the TTF can be considered source.
+ (build-system font-build-system)
+ (synopsis "Serif font for the Cyrillic, Greek, and Latin alphabets")
+ (description
+ "Gentium is a typeface family designed to enable the diverse ethnic
+groups around the world who use the Latin, Cyrillic and Greek scripts to
+produce readable, high-quality publications. The font comes with regular and
+italics shapes. This package provides only TrueType files (TTF).")
+ (home-page "https://software.sil.org/gentium/")
+ (license license:silofl1.1)))