aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-05-18 00:11:24 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-05-18 17:40:59 +0200
commit23e24ff6ccf7f71389e57ab2bc061f318b5dfc9e (patch)
treeb6594ae2d6ed0d09a86fa0b7d0b97413406b5d4e
parentf3d89181065aca4c08669f172f29fdb3f3ee7c69 (diff)
downloadguix-23e24ff6ccf7f71389e57ab2bc061f318b5dfc9e.tar
guix-23e24ff6ccf7f71389e57ab2bc061f318b5dfc9e.tar.gz
gnu: libmatroska: Update to 1.4.9.
* gnu/packages/video.scm (libmatroska): Update to 1.4.9. [build-system]: Switch to the CMake build system. [native-inputs]: Remove PKG-CONFIG. [arguments]: Build shared libaries and don't try to run non-existent tests.
-rw-r--r--gnu/packages/video.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index cfe8d3ba56..997cf57003 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -515,7 +515,7 @@ SMPTE 314M.")
(define-public libmatroska
(package
(name "libmatroska")
- (version "1.4.8")
+ (version "1.4.9")
(source
(origin
(method url-fetch)
@@ -523,12 +523,14 @@ SMPTE 314M.")
name "/" name "-" version ".tar.xz"))
(sha256
(base32
- "14n9sw974prr3yp4yjb7aadi6x2yz5a0hjw8fs3qigy5shh2piyq"))))
- (build-system gnu-build-system)
- (native-inputs
- `(("pkg-config" ,pkg-config)))
+ "1j4mjzx6mjzfjf9hz8g4w84krf5jccmr5cyynll0j1vwv3aiv9iq"))))
+ (build-system cmake-build-system)
(inputs
`(("libebml" ,libebml)))
+ (arguments
+ `(#:configure-flags
+ (list "-DBUILD_SHARED_LIBS=YES")
+ #:tests? #f)) ; no test suite
(home-page "https://www.matroska.org")
(synopsis "C++ library to parse Matroska files (.mkv and .mka)")
(description