aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2018-05-09 13:54:36 +0530
committerArun Isaac <arunisaac@systemreboot.net>2018-05-14 19:12:32 +0530
commit20b51b17d17b3a1b743ee8c3998af80c04e6cbd5 (patch)
tree06401b7d2b7d2505e061240fa6ef2b1c76c23087
parent34e00c7ba4686a5e589b8a0be25319302a4c0697 (diff)
downloadguix-20b51b17d17b3a1b743ee8c3998af80c04e6cbd5.tar
guix-20b51b17d17b3a1b743ee8c3998af80c04e6cbd5.tar.gz
gnu: Add pass-rotate.
* gnu/packages/password-utils.scm (pass-rotate): New variable.
-rw-r--r--gnu/packages/password-utils.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/password-utils.scm b/gnu/packages/password-utils.scm
index 902b709dba..011cf594d1 100644
--- a/gnu/packages/password-utils.scm
+++ b/gnu/packages/password-utils.scm
@@ -18,6 +18,7 @@
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2018 Konrad Hinsen <konrad.hinsen@fastmail.net>
;;; Copyright © 2018 Thomas Sigurdsen <tonton@riseup.net>
+;;; Copyright © 2018 Arun Isaac <arunisaac@systemreboot.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -62,6 +63,7 @@
#:use-module (gnu packages ncurses)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages python)
+ #:use-module (gnu packages python-web)
#:use-module (gnu packages suckless)
#:use-module (gnu packages tls)
#:use-module (gnu packages qt)
@@ -659,3 +661,30 @@ Upstream development seems to have stopped. It is therefore recommended
to use a different password manager.")
(home-page "https://als.regnet.cz/fpm2/")
(license license:gpl2+)))
+
+(define-public pass-rotate
+ (package
+ (name "pass-rotate")
+ (version "0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/SirCmpwn/pass-rotate/archive/"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1svm5nj8bczv2dg8lh2zqqhbsrljqsw9680r03qwgl9vlci90210"))
+ (file-name (string-append name "-" version ".tar.gz"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-beautifulsoup4" ,python-beautifulsoup4)
+ ("python-docopt" ,python-docopt)
+ ("python-html5lib" ,python-html5lib)
+ ("python-requests" ,python-requests)))
+ (home-page "https://github.com/SirCmpwn/pass-rotate")
+ (synopsis "Rotate password on online services")
+ (description "pass-rotate is a command line utility and python library for
+rotating passwords on various web services. It makes it easier to rotate your
+passwords, one at a time or in bulk, when security events or routine upkeep of
+your online accounts makes it necessary.")
+ (license license:expat)))