aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-03-20 22:03:35 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-20 22:41:59 +0100
commitfe36fdb206be6b189fa0bb5b4eb8074379431612 (patch)
treeeb66e927bc402c66117273e7968d9b669f6311d8
parent28030d290a9f690800d6ed7c7d0b217d7452b321 (diff)
downloadguix-fe36fdb206be6b189fa0bb5b4eb8074379431612.tar
guix-fe36fdb206be6b189fa0bb5b4eb8074379431612.tar.gz
gnu: Add python-random2.
* gnu/packages/python-xyz.scm (python-random2, python2-random2): New public variables.
-rw-r--r--gnu/packages/python-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 93b735f1c9..0c7e9e4599 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12163,6 +12163,34 @@ provide extendible implementations of common aspects of a cloud so that you can
focus on building massively scalable web applications.")
(license license:expat)))
+(define-public python-random2
+ (package
+ (name "python-random2")
+ (version "1.0.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "random2" version ".zip"))
+ (sha256
+ (base32
+ "01y0s4747plsx8fdnxy0nz83dp69naddz58m81r9h0s1qfm31b9l"))))
+ (build-system python-build-system)
+ (native-inputs `(("unzip" ,unzip)))
+ (home-page "http://pypi.python.org/pypi/random2")
+ (synopsis "Python 3 version of the Python 2 @code{random} module")
+ (description
+ "This package provides a Python 3 ported version of Python 2.7’s
+@code{random} module. It has also been back-ported to work in Python 2.6.
+
+In Python 3, the implementation of @code{randrange()} was changed, so that
+even with the same seed you get different sequences in Python 2 and 3.
+
+This package closes that gap, allowing stable random number generation
+between the different Python versions.")
+ (license license:psfl)))
+
+(define-public python2-random2
+ (package-with-python2 python-random2))
+
(define-public python-snowballstemmer
(package
(name "python-snowballstemmer")