aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-03-15 01:52:37 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-20 19:15:52 +0100
commitfcafee61bf26fcd3a16fb02aff500a328f5a33ac (patch)
treecca17868305eb9cde5bc224f172a184a4859f006
parent3861fb1c1f0e33ea714093e98da828d03acf21e5 (diff)
downloadguix-fcafee61bf26fcd3a16fb02aff500a328f5a33ac.tar
guix-fcafee61bf26fcd3a16fb02aff500a328f5a33ac.tar.gz
gnu: add premake5.
* gnu/packages/build-tools.scm (premake5): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/build-tools.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/build-tools.scm b/gnu/packages/build-tools.scm
index 63dc72e1a7..8cfd26fec0 100644
--- a/gnu/packages/build-tools.scm
+++ b/gnu/packages/build-tools.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2019 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
+;;; Copyright © 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -245,6 +246,31 @@ other lower-level build files.")
(home-page "https://premake.github.io")
(license license:bsd-3)))
+(define-public premake5
+ (package
+ (inherit premake4)
+ (version "5.0.0-alpha14")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://github.com/premake/premake-core/"
+ "releases/download/v" version
+ "/premake-" version "-src.zip"))
+ (sha256
+ (base32
+ "0236s7bjvxf7x1l5faywmfzjywflpx42ngyhkn0mqqjnh54a97vw"))))
+ (arguments
+ (substitute-keyword-arguments (package-arguments premake4)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (install-file "../../bin/release/premake5"
+ (string-append (assoc-ref outputs "out") "/bin"))
+ #t))))))
+ (description "@code{premake5} is a command line utility that reads a
+scripted definition of a software project and outputs @file{Makefile}s or
+other lower-level build files.")))
+
(define-public osc
(package
(name "osc")