aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-02-17 21:21:55 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-21 03:09:43 +0100
commitfa2a0fd00bc1a599a34144ea2c5aedc4e41fe237 (patch)
treee16d5d2824a472bf7767a1c6a6a31588a6b30b32
parent7ea838447c3cc07c35d45ba8ae43e64ae8ff36c3 (diff)
downloadguix-fa2a0fd00bc1a599a34144ea2c5aedc4e41fe237.tar
guix-fa2a0fd00bc1a599a34144ea2c5aedc4e41fe237.tar.gz
gnu: Use ‘license:’ prefix in (gnu packages libreoffice).
* gnu/packages/libreoffice.scm: Import (guix licenses) with a #:prefix and adjust all callers.
-rw-r--r--gnu/packages/libreoffice.scm72
1 files changed, 36 insertions, 36 deletions
diff --git a/gnu/packages/libreoffice.scm b/gnu/packages/libreoffice.scm
index 2ef813907d..88f31c7d1a 100644
--- a/gnu/packages/libreoffice.scm
+++ b/gnu/packages/libreoffice.scm
@@ -35,9 +35,7 @@
#:use-module (guix build-system trivial)
#:use-module (guix download)
#:use-module (guix git-download)
- #:use-module ((guix licenses)
- #:select (gpl2 gpl2+ lgpl2.1+ lgpl3+ mpl1.1 mpl2.0
- non-copyleft x11-style bsd-3))
+ #:use-module ((guix licenses) #:prefix license:)
#:use-module (guix packages)
#:use-module (guix utils)
#:use-module (ice-9 match)
@@ -110,7 +108,7 @@
expressions stored in multiple named targets, or \"cells\". The cells can
be referenced from each other, and the library takes care of resolving
their dependencies automatically upon calculation.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public orcus
(package
@@ -140,7 +138,7 @@ spreadsheet documents. The library includes import filters for
Microsoft Excel 2007 XML, Microsoft Excel 2003 XML, Open Document Spreadsheet,
Plain Text, Gnumeric XML, Generic XML. It also includes low-level parsers for
CSV, CSS and XML.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public unoconv
(package
@@ -197,7 +195,7 @@ Format (@file{.odt}, @file{.ods}, @file{.odp})), Portable Document Format
@file{.docx}), @file{.xls} and @file{.xlsx}).
All required fonts must be installed on the converting system.")
- (license gpl2)))
+ (license license:gpl2)))
(define-public librevenge
(package
@@ -229,7 +227,7 @@ All required fonts must be installed on the converting system.")
(description "Librevenge is a base library for writing document import
filters. It has interfaces for text documents, vector graphics,
spreadsheets and presentations.")
- (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
+ (license (list license:mpl2.0 license:lgpl2.1+)))) ; dual-licensed
(define-public libwpd
(package
@@ -257,7 +255,7 @@ spreadsheets and presentations.")
(description "Libwpd is a C++ library designed to help process
WordPerfect documents. It is most commonly used to import such documents
into other word processors.")
- (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
+ (license (list license:mpl2.0 license:lgpl2.1+)))) ; dual-licensed
(define-public libe-book
(package
@@ -294,7 +292,7 @@ Broad Band eBook, eReader .pdb, FictionBook v. 2 (including zipped files),
PalmDoc Ebook, Plucker .pdb, QiOO (mobile format, for java-enabled
cellphones), TCR (simple compressed text format), TealDoc, zTXT,
ZVR (simple compressed text format).")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libepubgen
(package
@@ -322,7 +320,7 @@ ZVR (simple compressed text format).")
(description "libepubgen is an EPUB generator for librevenge. It supports
librevenge's text document interface and--currently in a very limited
way--presentation and vector drawing interfaces.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libwpg
(package
@@ -348,7 +346,7 @@ way--presentation and vector drawing interfaces.")
(synopsis "Library and tools for the WordPerfect Graphics format")
(description "The libwpg project provides a library and tools for
working with graphics in the WPG (WordPerfect Graphics) format.")
- (license (list mpl2.0 lgpl2.1+)))) ;dual licensed
+ (license (list license:mpl2.0 license:lgpl2.1+)))) ; dual-licensed
(define-public libcmis
(package
@@ -390,7 +388,8 @@ working with graphics in the WPG (WordPerfect Graphics) format.")
(description "LibCMIS is a C++ client library for the CMIS interface. It
allows C++ applications to connect to any ECM behaving as a CMIS server such
as Alfresco or Nuxeo.")
- (license (list mpl1.1 gpl2+ lgpl2.1+)))) ; triple license
+ (license
+ (list license:mpl1.1 license:gpl2+ license:lgpl2.1+)))) ; triple license
(define-public libabw
(package
@@ -418,7 +417,7 @@ as Alfresco or Nuxeo.")
(synopsis "Library for parsing the AbiWord format")
(description "Libabw is a library that parses the file format of
AbiWord documents.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libcdr
(package
@@ -447,7 +446,7 @@ AbiWord documents.")
(synopsis "Library for parsing the CorelDRAW format")
(description "Libcdr is a library that parses the file format of
CorelDRAW documents of all versions.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libetonyek
(package
@@ -481,7 +480,7 @@ CorelDRAW documents of all versions.")
(synopsis "Library for parsing the Apple Keynote format")
(description "Libetonyek is a library that parses the file format of
Apple Keynote documents. It currently supports Keynote versions 2 to 5.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public liblangtag
(package
@@ -507,7 +506,7 @@ for identifying languages as described in RFC 5646. It supports the
extensions described in RFC6067 and RFC6497, and Extension T for
language/locale identifiers as described in the Unicode CLDR
standard 21.0.2.")
- (license (list lgpl3+ mpl2.0)))) ; dual license
+ (license (list license:lgpl3+ license:mpl2.0)))) ; dual license
(define-public libexttextcat
(package
@@ -525,8 +524,8 @@ standard 21.0.2.")
(synopsis "Text Categorization library")
(description "Libexttextcat is an N-Gram-Based Text Categorization
library primarily intended for language guessing.")
- (license (non-copyleft "file://LICENSE"
- "See LICENSE in the distribution."))))
+ (license (license:non-copyleft "file://LICENSE"
+ "See LICENSE in the distribution."))))
(define-public libfreehand
(package
@@ -556,7 +555,7 @@ library primarily intended for language guessing.")
(synopsis "Library for parsing the FreeHand format")
(description "Libfreehand is a library that parses the file format of
Aldus/Macromedia/Adobe FreeHand documents.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libmspub
(package
@@ -583,7 +582,7 @@ Aldus/Macromedia/Adobe FreeHand documents.")
(synopsis "Library for parsing the Microsoft Publisher format")
(description "Libmspub is a library that parses the file format of
Microsoft Publisher documents of all versions.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libnumbertext
(package
@@ -606,7 +605,7 @@ Microsoft Publisher documents of all versions.")
"The libnumbertext library provides language-neutral @code{NUMBERTEXT}
and @code{MONEYTEXT} functions for LibreOffice Calc, available for C++ and
Java.")
- (license (list lgpl3+ bsd-3))))
+ (license (list license:lgpl3+ license:bsd-3))))
(define-public libpagemaker
(package
@@ -635,7 +634,7 @@ Java.")
(description "Libpagemaker is a library that parses the file format of
Aldus/Adobe PageMaker documents. Currently it only understands documents
created by PageMaker version 6.x and 7.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libvisio
(package
@@ -665,7 +664,7 @@ created by PageMaker version 6.x and 7.")
(synopsis "Library for parsing the Microsoft Visio format")
(description "Libvisio is a library that parses the file format of
Microsoft Visio documents of all versions.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libodfgen
(package
@@ -696,7 +695,7 @@ Microsoft Visio documents of all versions.")
Open Document Format (ODF). It provides generator implementations for all
document interfaces supported by librevenge:
text documents, vector drawings, presentations and spreadsheets.")
- (license (list mpl2.0 lgpl2.1+)))) ; dual license
+ (license (list license:mpl2.0 license:lgpl2.1+)))) ; dual license
(define-public libmwaw
(package
@@ -723,7 +722,7 @@ text documents, vector drawings, presentations and spreadsheets.")
(description "Libmwaw contains some import filters for old Macintosh
text documents (MacWrite, ClarisWorks, ... ) and for some graphics and
spreadsheet documents.")
- (license (list mpl2.0 lgpl2.1+)))) ; dual license
+ (license (list license:mpl2.0 license:lgpl2.1+)))) ; dual license
(define-public libstaroffice
(package
@@ -746,7 +745,7 @@ spreadsheet documents.")
(synopsis "Provides LibreOffice support for old StarOffice documents")
(description "@code{libstaroffice} is an import filter for the document formats
from the old StarOffice (.sdc, .sdw, ...).")
- (license (list mpl2.0 lgpl2.1+)))) ; dual license
+ (license (list license:mpl2.0 license:lgpl2.1+)))) ; dual license
(define-public libwps
(package
@@ -772,7 +771,7 @@ from the old StarOffice (.sdc, .sdw, ...).")
(synopsis "Import library for Microsoft Works text documents")
(description "Libwps is a library for importing files in the Microsoft
Works word processor file format.")
- (license (list mpl2.0 lgpl2.1+)))) ; dual license
+ (license (list license:mpl2.0 license:lgpl2.1+)))) ; dual license
(define-public libzmf
(package
@@ -804,7 +803,7 @@ Works word processor file format.")
(description "Libzmf is a library that parses the file format of Zoner
Callisto/Draw documents. Currently it only understands documents created by
Zoner Draw version 4 and 5.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public hunspell
(package
@@ -836,7 +835,7 @@ Zoner Draw version 4 and 5.")
library and program designed for languages with rich morphology and complex
word compounding or character encoding.")
;; Triple license, including "mpl1.1 or later".
- (license (list mpl1.1 gpl2+ lgpl2.1+))))
+ (license (list license:mpl1.1 license:gpl2+ license:lgpl2.1+))))
(define (dicollecte-french-dictionary variant synopsis)
;; Return a French dictionary package from dicollecte.org, for the given
@@ -884,7 +883,7 @@ word compounding or character encoding.")
"This package provides a dictionary for the Hunspell spell-checking
library.")
(home-page "https://www.dicollecte.org/home.php?prj=fr")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-syntax define-french-dictionary
(syntax-rules (synopsis)
@@ -929,8 +928,9 @@ library.")
(synopsis "Hyphenation library")
(description "Hyphen is a hyphenation library using TeX hyphenation
patterns, which are pre-processed by a perl script.")
- ;; triple license, including "mpl1.1 or later"
- (license (list mpl1.1 mpl2.0 gpl2+ lgpl2.1+))))
+ ;; Triple license, including "mpl1.1 or later".
+ (license
+ (list license:mpl1.1 license:mpl2.0 license:gpl2+ license:lgpl2.1+))))
(define-public mythes
(package
@@ -954,8 +954,8 @@ patterns, which are pre-processed by a perl script.")
(description "MyThes is a simple thesaurus that uses a structured text
data file and an index file with binary search to look up words and phrases
and to return information on pronunciations, meanings and synonyms.")
- (license (non-copyleft "file://COPYING"
- "See COPYING in the distribution."))))
+ (license (license:non-copyleft "file://COPYING"
+ "See COPYING in the distribution."))))
(define-public libqxp
(package
@@ -982,7 +982,7 @@ and to return information on pronunciations, meanings and synonyms.")
(synopsis "Library and tools for the QuarkXPress file format")
(description "libqxp is a library and a set of tools for reading and
converting QuarkXPress file format. It supports versions 3.1 to 4.1.")
- (license mpl2.0)))
+ (license license:mpl2.0)))
(define-public libreoffice
(package
@@ -1203,4 +1203,4 @@ a number of components: Writer, a word processor; Calc, a spreadsheet
application; Impress, a presentation engine; Draw, a drawing and
flowcharting application; Base, a database and database frontend;
Math for editing mathematics.")
- (license mpl2.0)))
+ (license license:mpl2.0)))