aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrendan Tildesley <mail@brendan.scot>2020-03-15 20:36:16 +1100
committerMarius Bakke <mbakke@fastmail.com>2020-03-20 19:15:52 +0100
commitad64b09df4bcf0a57753c9ad2cdd442b78e205d3 (patch)
treea2a3db3c78e0913c667fefe7f0d2525c2d0fa345
parentfcafee61bf26fcd3a16fb02aff500a328f5a33ac (diff)
downloadguix-ad64b09df4bcf0a57753c9ad2cdd442b78e205d3.tar
guix-ad64b09df4bcf0a57753c9ad2cdd442b78e205d3.tar.gz
gnu: Add wev.
* gnu/packages/freedesktop.scm (wev): New variable. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/freedesktop.scm40
1 files changed, 39 insertions, 1 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index 1244da4fa0..b9811fb60e 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -10,7 +10,7 @@
;;; Copyright © 2017, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2017, 2018, 2019, 2020 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2017, 2018, 2019 Rutger Helling <rhelling@mykolab.com>
-;;; Copyright © 2017 Brendan Tildesley <mail@brendan.scot>
+;;; Copyright © 2017, 2020 Brendan Tildesley <mail@brendan.scot>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2018 Stefan Stefanović <stefanx2ovic@gmail.com>
@@ -72,6 +72,7 @@
#:use-module (gnu packages libunwind)
#:use-module (gnu packages libusb)
#:use-module (gnu packages linux)
+ #:use-module (gnu packages man)
#:use-module (gnu packages m4)
#:use-module (gnu packages nss)
#:use-module (gnu packages perl)
@@ -804,6 +805,43 @@ composes the final output. A Wayland compositor is essentially a
multiplexer to the KMS/DRM Linux kernel devices.")
(license license:expat)))
+(define-public wev
+ ;; There simple tool has no version or release yet.
+ (let ((commit "cee3dfb2a8b40ee303611018c68ae182d84a7f46"))
+ (package
+ (name "wev")
+ (version (string-append "2020-02-06-" (string-take commit 8)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~sircmpwn/wev")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0l71v3fzgiiv6xkk365q1l08qvaymxd4kpaya6r2g8yzkr7i2hms"))))
+ (build-system gnu-build-system)
+ (arguments
+ `(#:tests? #f ; no tests
+ #:make-flags
+ (list "CC=gcc" (string-append "PREFIX=" (assoc-ref %outputs "out")))
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure))))
+ (native-inputs
+ `(("pkg-config" ,pkg-config)
+ ("scdoc" ,scdoc)))
+ (inputs
+ `(("libxkbcommon" ,libxkbcommon)
+ ("wayland" ,wayland)
+ ("wayland-protocols" ,wayland-protocols)))
+ (home-page "https://git.sr.ht/~sircmpwn/wev")
+ (synopsis "Wayland event viewer")
+ (description "Wev is a tool that opens a window, printing all events
+sent to a Wayland window, such as key presses. It is analogous to the X11 tool
+XEv.")
+ (license license:expat))))
+
(define-public exempi
(package
(name "exempi")