aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2020-03-21 01:08:08 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2020-03-21 03:09:51 +0100
commitacf2b20069b1f74b59185292d981024eea4d7055 (patch)
tree57e5ccd43eb7268b341ff01731c0572de9e2be15
parentf9caa6c7c1af97c9f1da3a7fd033f88cbe4a9827 (diff)
downloadguix-acf2b20069b1f74b59185292d981024eea4d7055.tar
guix-acf2b20069b1f74b59185292d981024eea4d7055.tar.gz
gnu: rsync: Use system zlib and popt libraries.
Reduce our likelihood of contracting security bugs at the expense of compression ratio (in some cases) and compatibility with rsync≤3.1.1. rsync@3.1.2 was released in 2014. Time to upgrade your CentOS box. * gnu/packages/rsync.scm (rsync)[inputs]: Add popt and zlib. [arguments]: Use them.
-rw-r--r--gnu/packages/rsync.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/rsync.scm b/gnu/packages/rsync.scm
index 74efae753c..0d8217ee20 100644
--- a/gnu/packages/rsync.scm
+++ b/gnu/packages/rsync.scm
@@ -34,7 +34,6 @@
#:use-module (guix build-system cmake)
#:use-module (guix build-system gnu))
-
(define-public rsync
(package
(name "rsync")
@@ -47,10 +46,17 @@
(base32
"1h0011dj6jgqpgribir4anljjv7bbrdcs8g91pbsmzf5zr75bk2m"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:configure-flags
+ ;; The bundled copies are preferred by default.
+ (list "--without-included-zlib"
+ "--without-included-popt")))
(native-inputs
`(("perl" ,perl)))
(inputs
- `(("acl" ,acl)))
+ `(("acl" ,acl)
+ ("popt" ,popt)
+ ("zlib" ,zlib)))
(synopsis "Remote (and local) file copying tool")
(description
"Rsync is a fast and versatile file copying tool. It can copy locally,