aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLeo Prikler <leo.prikler@student.tugraz.at>2020-02-25 15:59:10 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-03-20 19:15:51 +0100
commit3861fb1c1f0e33ea714093e98da828d03acf21e5 (patch)
treed29e4e4fe85055eb23499aa95caca6ce58028896
parent0f6651344f4bf1736d9efc3b5523b2cec70f8ede (diff)
downloadguix-3861fb1c1f0e33ea714093e98da828d03acf21e5.tar
guix-3861fb1c1f0e33ea714093e98da828d03acf21e5.tar.gz
gnu: gsettings-desktop-schemas: patch monospace font.
* gnu/packages/gnome.scm (gsettings-desktop-schemas)[arguments]<phases>: Rename `set-adwaita-theme-file-name' to the more generic `patch-schemas'. Add patch for the monospace font (Source Code Pro 10 -> Monospace 11). Adjust comments. Signed-off-by: Marius Bakke <mbakke@fastmail.com>
-rw-r--r--gnu/packages/gnome.scm12
1 files changed, 7 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index c39b4467b9..bc78910c64 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -44,7 +44,7 @@
;;; Copyright © 2019 David Wilson <david@daviwil.com>
;;; Copyright © 2019, 2020 Raghav Gururajan <raghavgururajan@disroot.org>
;;; Copyright © 2019 Jonathan Brielmaier <jonathan.brielmaier@web.de>
-;;; Copyright © 2019 Leo Prikler <leo.prikler@student.tugraz.at>
+;;; Copyright © 2019, 2020 Leo Prikler <leo.prikler@student.tugraz.at>
;;; Copyright © 2020 Oleg Pykhalov <go.wigust@gmail.com>
;;; Copyright © 2020 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright © 2020 raingloom <raingloom@riseup.net>
@@ -1607,15 +1607,17 @@ on the GNOME Desktop with a single simple application.")
(build-system meson-build-system)
(arguments
'(#:phases (modify-phases %standard-phases
- (add-after 'unpack 'set-adwaita-theme-file-name
+ (add-after 'unpack 'patch-schemas
(lambda* (#:key inputs #:allow-other-keys)
- ;; Provide the correct file name of the default GNOME
- ;; background, 'adwaita-timed.xml'.
(let ((theme (assoc-ref inputs "gnome-backgrounds")))
(substitute* (find-files "schemas"
"\\.gschema\\.xml\\.in$")
+ ;; Provide the correct file name of the default GNOME
+ ;; background, 'adwaita-timed.xml'.
(("@datadir@/backgrounds/gnome")
- (string-append theme "/share/backgrounds/gnome")))
+ (string-append theme "/share/backgrounds/gnome"))
+ ;; Do not reference fonts, that may not exist.
+ (("'Source Code Pro 10'") "'Monospace 11'"))
#t))))))
(inputs
`(("glib" ,glib)