aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2020-03-19 19:54:46 +0100
committerDanny Milosavljevic <dannym@scratchpost.org>2020-03-19 20:45:00 +0100
commit15c3aa091100160bbe9c81650f9ab7a12bd7964e (patch)
tree80b5257f88a9db2dba91599f737e5396a15aed75
parentcc96c9504d22c0a0a4a146436a74c24d348241ae (diff)
downloadguix-15c3aa091100160bbe9c81650f9ab7a12bd7964e.tar
guix-15c3aa091100160bbe9c81650f9ab7a12bd7964e.tar.gz
gnu: docker-compose: Update to 1.25.4.
Fixes <https://bugs.gnu.org/40015>. * gnu/packages/docker.scm (docker-compose): Update to 1.25.4. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org>
-rw-r--r--gnu/packages/docker.scm11
-rw-r--r--gnu/packages/python-xyz.scm26
2 files changed, 5 insertions, 32 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index 7524a0dc1b..69dee2b856 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2018 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -98,19 +99,17 @@ pseudo-terminal (PTY) allocated to a Docker container using the Python
client.")
(license license:asl2.0)))
-;; When updating, check whether python-jsonschema-2.6 can be removed from Guix
-;; entirely.
(define-public docker-compose
(package
(name "docker-compose")
- (version "1.24.1")
+ (version "1.25.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "docker-compose" version))
(sha256
(base32
- "0lx7bx6jvhydbab8vwry0bclhdf0dfj6jrns1m5y45yp9ybqxmd5"))))
+ "1ww8ckpj3n5jdg63qvmiqx3gk0fsrnynnnqj17fppymbwjzf5fps"))))
(build-system python-build-system)
;; TODO: Tests require running Docker daemon.
(arguments '(#:tests? #f))
@@ -120,9 +119,9 @@ client.")
("python-docker-py" ,python-docker-py)
("python-dockerpty" ,python-dockerpty)
("python-docopt" ,python-docopt)
- ("python-jsonschema" ,python-jsonschema-2.6)
+ ("python-jsonschema" ,python-jsonschema)
("python-pyyaml" ,python-pyyaml)
- ("python-requests" ,python-requests-2.20)
+ ("python-requests" ,python-requests)
("python-six" ,python-six)
("python-texttable" ,python-texttable)
("python-websocket-client" ,python-websocket-client)))
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 07199aa7ca..8271e1ff7e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -2306,32 +2306,6 @@ compare, diff, and patch JSON and JSON-like structures in Python.")
`(("python2-functools32" ,python2-functools32)
,@(package-propagated-inputs jsonschema))))))
-;; This old version is still required by docker-compose as of 1.24.0.
-(define-public python-jsonschema-2.6
- (package
- (name "python-jsonschema")
- (version "2.6.0")
- (source (origin
- (method url-fetch)
- (uri (pypi-uri "jsonschema" version))
- (sha256
- (base32
- "00kf3zmpp9ya4sydffpifn0j0mzm342a2vzh82p6r0vh10cg7xbg"))))
- (build-system python-build-system)
- (arguments
- '(#:phases
- (modify-phases %standard-phases
- (replace 'check (lambda _ (invoke "nosetests"))))))
- (native-inputs
- `(("python-nose" ,python-nose)
- ("python-vcversioner" ,python-vcversioner)))
- (home-page "https://github.com/Julian/jsonschema")
- (synopsis "Implementation of JSON Schema for Python")
- (description
- "Jsonschema is an implementation of JSON Schema for Python.")
- (license license:expat)
- (properties `((python2-variant . ,(delay python2-jsonschema))))))
-
(define-public python-schema
(package
(name "python-schema")