aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorguy fleury iteriteka <gfleury@disroot.org>2020-03-18 09:54:57 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-03-20 19:15:52 +0100
commit0f7e6964c7b0daa715ebbd8ef6fe6f875ba47b85 (patch)
tree2b9196a5086c4ca75b47afb3aa5b5a0e68ddc025
parent12eb7bb8af3272bb1f16a9b73a3232e1294bd56f (diff)
downloadguix-0f7e6964c7b0daa715ebbd8ef6fe6f875ba47b85.tar
guix-0f7e6964c7b0daa715ebbd8ef6fe6f875ba47b85.tar.gz
gnu: make-libiberty: Use install-file.
* gnu/packages/gcc.scm(make-libiberty): In phase install use install-file helper function to install file.
-rw-r--r--gnu/packages/gcc.scm28
1 files changed, 12 insertions, 16 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 589e9367da..3d1ae25dc9 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -8,6 +8,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
;;; Copyright © 2020 Joseph LaFreniere <joseph@lafreniere.xyz>
+;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -578,22 +579,17 @@ using compilers other than GCC."
#:phases
(modify-phases %standard-phases
(add-before 'configure 'chdir
- (lambda _
- (chdir "libiberty")
- #t))
- (replace
- 'install
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (lib (string-append out "/lib/"))
- (include (string-append out "/include/")))
- (mkdir-p lib)
- (mkdir-p include)
- (copy-file "libiberty.a"
- (string-append lib "libiberty.a"))
- (copy-file "../include/libiberty.h"
- (string-append include "libiberty.h"))
- #t))))))
+ (lambda _
+ (chdir "libiberty")
+ #t))
+ (replace 'install
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (lib (string-append out "/lib/"))
+ (include (string-append out "/include/")))
+ (install-file "libiberty.a" lib)
+ (install-file "../include/libiberty.h" include))
+ #t)))))
(inputs '())
(outputs '("out"))
(native-inputs '())