aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-04 14:47:42 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-04 14:48:43 +0200
commite9096ef105c8f3d4667e55b4d94a1b1493659e2d (patch)
treebf54d132393cd95ff900ac2cecb1ff80e8b6c4f1
parent3e5d811387d8cd6a3eca0f50b55d728c5f6382f5 (diff)
downloadguix-e9096ef105c8f3d4667e55b4d94a1b1493659e2d.tar
guix-e9096ef105c8f3d4667e55b4d94a1b1493659e2d.tar.gz
gnu: python-plotly: Allow test phase to be skipped.
* gnu/packages/graph.scm (python-plotly)[arguments]: Wrap custom 'check phase tests with test with tests? keyword.
-rw-r--r--gnu/packages/graph.scm14
1 files changed, 8 insertions, 6 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 6110c7a91b..d2e4c875a1 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -170,12 +170,14 @@ lines.")
(chdir "packages/python/plotly")
#t))
(replace 'check
- (lambda _
- (invoke "pytest" "-x" "plotly/tests/test_core")
- (invoke "pytest" "-x" "plotly/tests/test_io")
- ;; FIXME: Add optional dependencies and enable their tests.
- ;; (invoke "pytest" "-x" "plotly/tests/test_optional")
- (invoke "pytest" "_plotly_utils/tests")))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "pytest" "-x" "plotly/tests/test_core")
+ (invoke "pytest" "-x" "plotly/tests/test_io")
+ ;; FIXME: Add optional dependencies and enable their tests.
+ ;; (invoke "pytest" "-x" "plotly/tests/test_optional")
+ (invoke "pytest" "_plotly_utils/tests"))
+ #t))
(add-before 'reset-gzip-timestamps 'make-files-writable
(lambda* (#:key outputs #:allow-other-keys)
(let ((out (assoc-ref outputs "out")))