aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2021-03-04 14:43:01 +0200
committerEfraim Flashner <efraim@flashner.co.il>2021-03-04 14:48:43 +0200
commit3e5d811387d8cd6a3eca0f50b55d728c5f6382f5 (patch)
tree4eb3350f31a0cc6f3d94a129e8a6f36df42afbf2
parent865728dd52600c7aa29a87bf18cb02ddf453cdfc (diff)
downloadguix-3e5d811387d8cd6a3eca0f50b55d728c5f6382f5.tar
guix-3e5d811387d8cd6a3eca0f50b55d728c5f6382f5.tar.gz
gnu: python-plotly: Update to 4.14.3.
* gnu/packages/graph.scm (python-plotly): Update to 4.14.3. [propagated-inputs]: Remove python-decorator. Add python-ipython, python-pillow. Move python-ipywidgets, python-xarray ... [native-inputs]: ... to here.
-rw-r--r--gnu/packages/graph.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/graph.scm b/gnu/packages/graph.scm
index 86c4b98bf1..6110c7a91b 100644
--- a/gnu/packages/graph.scm
+++ b/gnu/packages/graph.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2017, 2018, 2019, 2020 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2018 Joshua Sierles, Nextjournal <joshua@nextjournal.com>
;;; Copyright © 2018, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
-;;; Copyright © 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2019, 2021 Efraim Flashner <efraim@flashner.co.il>
;;; Copyright © 2019 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2020 Alexander Krotov <krotov@iitp.ru>
;;; Copyright © 2020 Pierre Langlois <pierre.langlos@gmx.com>
@@ -151,7 +151,7 @@ lines.")
(define-public python-plotly
(package
(name "python-plotly")
- (version "4.8.1")
+ (version "4.14.3")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -160,7 +160,7 @@ lines.")
(file-name (git-file-name name version))
(sha256
(base32
- "08ab677gr85m10zhixr6dnmlfws8q6sra7nhyb8nf3r8dx1ffqhz"))))
+ "02wlgy7gf3v5ckiq9ab3prm53cckxkavlghqgkk9xw2sfmmrn61q"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -183,16 +183,17 @@ lines.")
(find-files out "\\.gz"))
#t))))))
(native-inputs
- `(("python-pytest" ,python-pytest)))
+ `(("python-ipywidgets" ,python-ipywidgets)
+ ("python-pytest" ,python-pytest)
+ ("python-xarray" ,python-xarray)))
(propagated-inputs
- `(("python-decorator" ,python-decorator)
- ("python-ipywidgets" ,python-ipywidgets)
+ `(("python-ipython" ,python-ipython)
("python-pandas" ,python-pandas)
+ ("python-pillow" ,python-pillow)
("python-requests" ,python-requests)
("python-retrying" ,python-retrying)
("python-six" ,python-six)
- ("python-statsmodels" ,python-statsmodels)
- ("python-xarray" ,python-xarray)))
+ ("python-statsmodels" ,python-statsmodels)))
(home-page "https://plotly.com/python/")
(synopsis "Interactive plotting library for Python")
(description "Plotly's Python graphing library makes interactive,