aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 12:47:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 13:18:42 +0200
commite36058634d1754ab6d69f01a448efd691c2a1637 (patch)
treecaa10c6c84fde41e2c929a728a5c719e98ee44e5
parent6f05556ba77def387d862ee44d6658d8d647ad3c (diff)
downloadguix-e36058634d1754ab6d69f01a448efd691c2a1637.tar
guix-e36058634d1754ab6d69f01a448efd691c2a1637.tar.gz
gnu: python-hdf4: Use INVOKE.
* gnu/packages/python.scm (python-hdf4)[arguments]: Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/python.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6927924a68..b8521fa0e4 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -767,8 +767,8 @@ and verifies that it matches the intended target hostname.")
(setenv "PYTHONPATH"
(string-append (getcwd) ":"
(getenv "PYTHONPATH")))
- (and (zero? (system* "./runexamples.sh"))
- (zero? (system* "nosetests" "-v"))))))))
+ (invoke "./runexamples.sh")
+ (invoke "nosetests" "-v"))))))
(home-page "https://github.com/fhs/python-hdf4")
(synopsis "Python interface to the NCSA HDF4 library")
(description