aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul Garlick <pgarlick@tourbillion-technology.com>2018-09-20 18:59:56 +0100
committerLudovic Courtès <ludo@gnu.org>2018-09-21 17:04:37 +0200
commitb0d1e60fff023e405c92c45b3c78538c3cbb7e6b (patch)
treedf44dd16764bedc5aed20fc49741c926daaf30cf
parent10e066f410d1ffb9505f4fd0b5cc73e8af2154b0 (diff)
downloadguix-b0d1e60fff023e405c92c45b3c78538c3cbb7e6b.tar
guix-b0d1e60fff023e405c92c45b3c78538c3cbb7e6b.tar.gz
gnu: hdf5: Allow for absence of utility script.
* gnu/packages/maths.scm (hdf5)[arguments]: Add condition to 'split' phase to check for existence of h5fc script. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/maths.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm
index 736bac163e..30f1610c1d 100644
--- a/gnu/packages/maths.scm
+++ b/gnu/packages/maths.scm
@@ -814,8 +814,11 @@ incompatible with HDF5.")
(mkdir-p flib)
(mkdir-p finc)
(mkdir-p fex)
- (rename-file (string-append bin "/h5fc")
- (string-append fbin "/h5fc"))
+ ;; Note: When built with --enable-parallel, the 'h5fc' file
+ ;; doesn't exist, hence this condition.
+ (when (file-exists? (string-append bin "/h5fc"))
+ (rename-file (string-append bin "/h5fc")
+ (string-append fbin "/h5fc")))
(for-each (lambda (file)
(rename-file file
(string-append flib "/" (basename file))))