aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 12:58:02 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-09-21 13:18:42 +0200
commita1d6610e84f4ff61913e1e861093b38c2beb9614 (patch)
tree51780e37dcdbb93f54ae8fd2d4be63b7cc8068e0
parente36058634d1754ab6d69f01a448efd691c2a1637 (diff)
downloadguix-a1d6610e84f4ff61913e1e861093b38c2beb9614.tar
guix-a1d6610e84f4ff61913e1e861093b38c2beb9614.tar.gz
gnu: python-rencode: Update to 1.0.5.
* gnu/packages/python.scm (python-rencode): Update to 1.0.5. [arguments]: Add a 'delete-bogus-test' phase.
-rw-r--r--gnu/packages/python.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index b8521fa0e4..64ee4e028e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -12456,15 +12456,24 @@ library.")
(define-public python-rencode
(package
(name "python-rencode")
- (version "1.0.3")
+ (version "1.0.5")
(source
(origin
(method url-fetch)
(uri (pypi-uri "rencode" version))
(sha256
(base32
- "08if5yax1xn5yfp8p3765ccjmfcv9di7i4m5jckgnwvdsgznwkbj"))))
+ "0mzwdq1is7kyyr32i5k4iz6g5xxdvmiyc132jnc60p9m6lnwjrpv"))))
(build-system python-build-system)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'delete-bogus-test
+ ;; This test requires /home/aresch/Downloads, which is not provided by
+ ;; the build environment.
+ (lambda _
+ (delete-file "rencode/t.py")
+ #t)))))
(native-inputs `(("pkg-config" ,pkg-config)
("python-cython" ,python-cython)))
(home-page "https://github.com/aresch/rencode")