aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 04:09:14 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 09:25:36 +0100
commit6d286d82046479661dcaf3add91912b216b6e358 (patch)
tree4c506e9603014bfa319531b1f5edd250cc7a6884
parent581ae110de2f326fbfeb1c789ec1801997ea9566 (diff)
downloadguix-6d286d82046479661dcaf3add91912b216b6e358.tar
guix-6d286d82046479661dcaf3add91912b216b6e358.tar.gz
gnu: nginx, nginx-documentation: End phases with #t.
* gnu/packages/web.scm (nginx, nginx-documentation)[arguments]: End phases with #t. Substitute INVOKE for SYSTEM*.
-rw-r--r--gnu/packages/web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 08485cadb2..3a3311003f 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -230,7 +230,8 @@ Interface} specification.")
(setenv "CC" "gcc")
(format #t "environment variable `CC' set to `gcc'~%")
(format #t "configure flags: ~s~%" flags)
- (zero? (apply system* "./configure" flags)))))
+ (apply invoke "./configure" flags)
+ #t)))
(add-after 'install 'install-man-page
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -251,7 +252,8 @@ Interface} specification.")
(rename-file (string-append out "/conf")
(string-append share "/conf"))
(rename-file (string-append out "/html")
- (string-append share "/html"))))))))
+ (string-append share "/html"))
+ #t))))))
(home-page "https://nginx.org")
(synopsis "HTTP and reverse proxy server")
(description
@@ -343,7 +345,8 @@ documentation.")
(("#banner \\{ background: black;")
"#banner { background: black;
display: none;"))
- (zero? (system* "make")))))
+ (invoke "make")
+ #t)))
(replace 'install
(lambda* (#:key outputs #:allow-other-keys)
(let ((output (assoc-ref outputs "out")))