aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Sturmfels <ben@sturm.com.au>2018-01-21 18:43:07 +1100
committerLeo Famulari <leo@famulari.name>2018-01-30 00:17:13 -0500
commit526789a1acb14cf930a756e968b4de8cb9d95188 (patch)
treefb4cf7e56c7f0dc6c39fec61eaacbcb673acbcda
parent6f4e8693e7b0c5d830eafa8a69c3559390f13369 (diff)
downloadguix-526789a1acb14cf930a756e968b4de8cb9d95188.tar
guix-526789a1acb14cf930a756e968b4de8cb9d95188.tar.gz
gnu: python-uniseg: Switch to PyPi source to get missing ucd.sqlite3.
Fixes <https://bugs.gnu.org/30189>. * gnu/packages/python.scm (python-uniseg)[source]: Fetch from PyPi. [native-inputs]: Add unzip. Signed-off-by: Leo Famulari <leo@famulari.name>
-rw-r--r--gnu/packages/python.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e4d5edb41f..94551da331 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -821,15 +821,15 @@ Python 3 support.")
(source
(origin
(method url-fetch)
- (uri (string-append "https://bitbucket.org/emptypage/uniseg-python/"
- "get/rel-" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (pypi-uri "uniseg" version ".zip"))
(sha256
(base32
- "1df4gddnj2a0v8z35wb2ra5vvh1f1qyxs8fgd25c8g64031mna6x"))))
+ "05jsazvz6nbmh6l3v1rph5ydkqn1hzx1pyggdyvgp2qgmgrnmiz2"))))
(build-system python-build-system)
(arguments
'(#:tests? #f)) ; The test suite requires network access.
+ (native-inputs
+ `(("unzip" ,unzip)))
(home-page
"https://bitbucket.org/emptypage/uniseg-python")
(synopsis