aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-01-29 22:13:29 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-01-29 23:40:23 +0100
commit50e8790335e85546c9d29cdae070a87368e9662c (patch)
treea0ed1a32151d54e653183c186ded3744613b296f
parent57f9671d22bb4ee37962c31b9eed0ae50859398a (diff)
downloadguix-50e8790335e85546c9d29cdae070a87368e9662c.tar
guix-50e8790335e85546c9d29cdae070a87368e9662c.tar.gz
gnu: libsepol: Fix build on non-x86_64.
* gnu/packages/selinux.scm (libsepol)[arguments]: Add phase "portability". (checkpolicy, libselinux, libsemanage, secilc, python-sepolgen, python-setools, policycoreutils)[arguments]: Remove inherited phase "portability".
-rw-r--r--gnu/packages/selinux.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/selinux.scm b/gnu/packages/selinux.scm
index 99f9e76e29..3db1b458c7 100644
--- a/gnu/packages/selinux.scm
+++ b/gnu/packages/selinux.scm
@@ -73,7 +73,14 @@
(modify-phases %standard-phases
(delete 'configure)
(add-after 'unpack 'enter-dir
- (lambda _ (chdir ,name) #t)))))
+ (lambda _ (chdir ,name) #t))
+ (add-after 'enter-dir 'portability
+ (lambda _
+ (substitute* "src/ibpkeys.c"
+ (("#include \"ibpkey_internal.h\"" line)
+ (string-append line "\n#include <inttypes.h>\n"))
+ (("%#lx") "%#\" PRIx64 \""))
+ #t)))))
(native-inputs
`(("flex" ,flex)))
(home-page "https://selinuxproject.org/")
@@ -101,6 +108,7 @@ boolean settings).")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (delete 'portability)
(add-after 'unpack 'enter-dir
(lambda _ (chdir ,name) #t)))))
(inputs
@@ -136,6 +144,7 @@ module into a binary representation.")
,flags))
((#:phases phases)
`(modify-phases ,phases
+ (delete 'portability)
(replace 'enter-dir
(lambda _ (chdir ,name) #t))
(add-after 'enter-dir 'remove-Werror
@@ -187,6 +196,7 @@ the core SELinux management utilities.")
,flags))
((#:phases phases)
`(modify-phases ,phases
+ (delete 'portability)
(replace 'enter-dir
(lambda _ (chdir ,name) #t))
(add-after 'build 'pywrap
@@ -228,6 +238,7 @@ binary policies.")
,flags)))
((#:phases phases)
`(modify-phases ,phases
+ (delete 'portability)
(replace 'enter-dir
(lambda _ (chdir ,name) #t))))))
(inputs
@@ -250,6 +261,7 @@ binary policies.")
,@(substitute-keyword-arguments (package-arguments libsepol)
((#:phases phases)
`(modify-phases ,phases
+ (delete 'portability)
(replace 'enter-dir
(lambda _ (chdir "python/sepolgen") #t))
;; By default all Python files would be installed to
@@ -310,6 +322,7 @@ based on required access.")
`(#:tests? #f ; the test target causes a rebuild
#:phases
(modify-phases %standard-phases
+ (delete 'portability)
(add-after 'unpack 'set-SEPOL-variable
(lambda* (#:key inputs #:allow-other-keys)
(setenv "SEPOL"
@@ -372,6 +385,7 @@ tools, and libraries designed to facilitate SELinux policy analysis.")
#:phases
(modify-phases %standard-phases
(delete 'configure)
+ (delete 'portability)
(add-after 'unpack 'enter-dir
(lambda _ (chdir ,name) #t))
(add-after 'enter-dir 'ignore-/usr-tests