aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2018-01-21 10:52:34 +0000
committerChristopher Baines <mail@cbaines.net>2018-01-30 07:41:30 +0000
commit210c6d959d9a6f6dec60c5f4592bbca7afc11ae8 (patch)
tree181823ad072f219a7ef0c600930a842d111bad72
parent5807172300f71eda29c4dc7ed11badc5ce63b299 (diff)
downloadguix-210c6d959d9a6f6dec60c5f4592bbca7afc11ae8.tar
guix-210c6d959d9a6f6dec60c5f4592bbca7afc11ae8.tar.gz
gnu: Add go-gopkg.in-tomb.v2.
* gnu/packages/golang.scm (go-gopkg.in-tomb.v2): New variable.
-rw-r--r--gnu/packages/golang.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 323786c6d4..b8eb90ed9e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -471,3 +471,28 @@ functionality is similar to the go builtin @code{flag} package, but
way of specifying command line options.")
(home-page "https://github.com/jessevdk/go-flags")
(license license:bsd-3)))
+
+(define-public go-gopkg.in-tomb.v2
+ (let ((commit "d5d1b5820637886def9eef33e03a27a9f166942c")
+ (revision "0"))
+ (package
+ (name "go-gopkg.in-tomb.v2")
+ (version (string-append "0.0.0-" revision "." (string-take commit 7)))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-tomb/tomb.git")
+ (commit commit)))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1sv15sri99szkdz1bkh0ir46w9n8prrwx5hfai13nrhkawfyfy10"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "gopkg.in/tomb.v2"))
+ (synopsis "@code{tomb} handles clean goroutine tracking and termination")
+ (description
+ "The @code{tomb} package handles clean goroutine tracking and
+termination.")
+ (home-page "https://gopkg.in/tomb.v2")
+ (license license:bsd-3))))