aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 05:24:19 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-30 09:25:37 +0100
commit004450f42a10d2df8535aa5326d94bd044e9cbb8 (patch)
treece05a12914cb937ee8408254121fdbcac3b3f002
parent0a0eb42f10588e10d6f81074419e24a416a37f99 (diff)
downloadguix-004450f42a10d2df8535aa5326d94bd044e9cbb8.tar
guix-004450f42a10d2df8535aa5326d94bd044e9cbb8.tar.gz
gnu: libbluray: Update to 1.0.2.
* gnu/packages/video.scm (libbluray): Update to 1.0.2. [arguments]: Add `refer-to-libxml2-in-.pc-file' phase.
-rw-r--r--gnu/packages/video.scm15
1 files changed, 13 insertions, 2 deletions
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 2d48c5aaf7..d149cc5738 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1309,7 +1309,7 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
(define-public libbluray
(package
(name "libbluray")
- (version "1.0.1")
+ (version "1.0.2")
(source (origin
(method url-fetch)
(uri (string-append "https://download.videolan.org/videolan/"
@@ -1317,12 +1317,23 @@ audio, images) from the Web. It can use either mpv or vlc for playback.")
name "-" version ".tar.bz2"))
(sha256
(base32
- "0fl5cxfj870rwqmmz3s04wh7wnabb7rnynfj1v3sz37ln8frm7qg"))))
+ "1zxfnw1xbghcj7b3zz5djndv6gwssxda19cz1lrlqrkg8577r7kd"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags '("--disable-bdjava-jar")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'refer-to-libxml2-in-.pc-file
+ ;; Avoid the need to propagate libxml2 by referring to it
+ ;; directly, as is already done for fontconfig & freetype.
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((libxml2 (assoc-ref inputs "libxml2")))
+ (substitute* "configure"
+ ((" libxml-2.0") ""))
+ (substitute* "src/libbluray.pc.in"
+ (("^Libs.private:" field)
+ (string-append field " -L" libxml2 "/lib -lxml2")))
+ #t)))
(add-before 'build 'fix-dlopen-paths
(lambda* (#:key inputs #:allow-other-keys)
(let ((libaacs (assoc-ref inputs "libaacs"))