aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-27 19:00:40 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-27 19:03:43 +0200
commite821a6406a1b380e4fd494a9b2dea07664a655b0 (patch)
treeb47e4e0d325d63ac8f8f0ecedb75d6b779a39eb4
parentbcc718be031ac550a3a3cde718ac7cffca8a0fa5 (diff)
downloadguix-e821a6406a1b380e4fd494a9b2dea07664a655b0.tar
guix-e821a6406a1b380e4fd494a9b2dea07664a655b0.tar.gz
gnu: ocaml-qtest: Update to 2.9.
* gnu/packages/ocaml.scm (ocaml-qtest): Update to 2.9. [source]: Use git-fetch. [build-system]: Use dune-build-system.
-rw-r--r--gnu/packages/ocaml.scm27
1 files changed, 11 insertions, 16 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index da04c7e6a0..efba539fa8 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1214,28 +1214,23 @@ instances and printing them.")
(define-public ocaml-qtest
(package
(name "ocaml-qtest")
- (version "2.8")
+ (version "2.9")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/vincent-hugot/qtest/"
- "archive/" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/vincent-hugot/qtest/")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1ff4if64mc9c7wmhjdgnlnh6k6a713piqzr4043zzj4s5pw7smxk"))))
- (build-system ocaml-build-system)
- (native-inputs
- `(("ocamlbuild" ,ocamlbuild)))
+ "1ifxc8jndwah82g5k8xaa7jskbv866j4zpd0w41f0pskg4y0z9g1"))))
+ (build-system dune-build-system)
+ (arguments
+ `(#:jbuild? #t
+ #:test-target "tests"))
(propagated-inputs
`(("ounit" ,ocaml-ounit)
("qcheck" ,ocaml-qcheck)))
- (arguments
- `(#:tests? #f ; No test target.
- #:make-flags
- (list (string-append "BIN=" (assoc-ref %outputs "out") "/bin"))
- #:phases
- (modify-phases %standard-phases
- (delete 'configure))))
(home-page "https://github.com/vincent-hugot/qtest")
(synopsis "Inline (Unit) Tests for OCaml")
(description "Qtest extracts inline unit tests written using a special