aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 23:52:57 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 23:57:00 +0200
commitb05290380f6f419a05248d755d7dc9092cc1a3a8 (patch)
tree9f6638a90a27f6857e3f048676db5c0f2a764dfd
parentcf338cc3051c113229ce7519a56446f29b9a24a2 (diff)
downloadguix-b05290380f6f419a05248d755d7dc9092cc1a3a8.tar
guix-b05290380f6f419a05248d755d7dc9092cc1a3a8.tar.gz
gnu: ocaml-ppxlib: Update to 0.6.0.
* gnu/packages/ocaml.scm (ocaml-ppxlib): Update to 0.6.0. (dune): Update to 1.9.1.
-rw-r--r--gnu/packages/ocaml.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 9171a017a6..31bdf62b5e 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -1322,14 +1322,14 @@ coverage information.")
(define-public dune
(package
(name "dune")
- (version "1.6.3")
+ (version "1.9.1")
(source (origin
(method url-fetch)
(uri (string-append "https://github.com/ocaml/dune/releases/"
"download/" version "/dune-" version ".tbz"))
(sha256
(base32
- "0dmf0wbfmgdy5plz1bjiisc2hjgblvxsnrqjmw2c8y45v1h23mdz"))))
+ "0z4jnj0a5vxjqlwksplhag9b3s3iqdcpcpjjzfazv5jdl5cf58f9"))))
(build-system ocaml-build-system)
(arguments
`(#:tests? #f; require odoc
@@ -3891,7 +3891,7 @@ as part of the same ocaml-migrate-parsetree driver.")
(define-public ocaml-ppxlib
(package
(name "ocaml-ppxlib")
- (version "0.4.0")
+ (version "0.6.0")
(home-page "https://github.com/ocaml-ppx/ppxlib")
(source
(origin
@@ -3902,7 +3902,7 @@ as part of the same ocaml-migrate-parsetree driver.")
(file-name (git-file-name name version))
(sha256
(base32
- "1nr4igf5m4prvigvv470dnhfdhdw0p6hz6zw8gnm5bzcv7s2lg5l"))))
+ "0my9x7sxb329h0lzshppdaawiyfbaw6g5f41yiy7bhl071rnlvbv"))))
(build-system dune-build-system)
(propagated-inputs
`(("ocaml-base" ,ocaml-base)
@@ -3923,6 +3923,7 @@ as part of the same ocaml-migrate-parsetree driver.")
(findlib-libdir
(string-append findlib-path "/lib/ocaml/site-lib")))
(substitute* '("test/base/test.ml"
+ "test/code_path/test.ml"
"test/deriving/test.ml"
"test/driver/attributes/test.ml"
"test/driver/non-compressible-suffix/test.ml"