aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-04-26 19:26:28 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-04-26 21:00:41 +0200
commit152cbc3ca588be8a0db8bd1c9a9746068542e449 (patch)
treebe82e2f8fa5784dd23d3d2646f23c947d5acd65f
parent7f55904558e0f481d2f60ab52510c7e126c73fd0 (diff)
downloadguix-152cbc3ca588be8a0db8bd1c9a9746068542e449.tar
guix-152cbc3ca588be8a0db8bd1c9a9746068542e449.tar.gz
gnu: r-with-tests: Update to 3.6.0.
* gnu/packages/statistics.scm (r-with-tests): Update to 3.6.0. [arguments]: Adjust "build-reproducibly" phase. [native-inputs]: Add a texlive-union consisting of texlive-fonts-amsfonts, texlive-fonts-ec, texlive-latex-amsfonts, texlive-latex-base, texlive-latex-fancyvrb, texlive-latex-graphics, texlive-latex-hyperref, texlive-latex-oberdiek, texlive-latex-tools, texlive-latex-upquote, and texlive-latex-url.
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 18 insertions, 2 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 7cd81b6358..1accfd7d27 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -68,6 +68,7 @@
#:use-module (gnu packages readline)
#:use-module (gnu packages ssh)
#:use-module (gnu packages tcl)
+ #:use-module (gnu packages tex)
#:use-module (gnu packages texinfo)
#:use-module (gnu packages time)
#:use-module (gnu packages tls)
@@ -177,7 +178,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
(define r-with-tests
(package
(name "r-with-tests")
- (version "3.5.3")
+ (version "3.6.0")
(source (origin
(method url-fetch)
(uri (string-append "mirror://cran/src/base/R-"
@@ -185,7 +186,7 @@ This package also provides @command{xls2csv} to export Excel files to CSV.")
version ".tar.gz"))
(sha256
(base32
- "1337irx9y0r3jm1rcq1dcwnxsgfhnvgjs5wadcyh17vhpnvkgyib"))))
+ "02bmylmzrm9sdidirmwy233lghmd2346z725ca71ari68lzarz1n"))))
(build-system gnu-build-system)
(arguments
`(#:disallowed-references (,tzdata-for-tests)
@@ -251,6 +252,10 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
(("(install_package_description\\(.*\"')\\)\"" line prefix)
(string-append prefix ", builtStamp='1970-01-01')\"")))
+ (substitute* "src/library/Recommended/Makefile.in"
+ (("INSTALL_OPTS =" m)
+ (string-append m " --built-timestamp=1970-01-01" m)))
+
;; R bundles an older version of help2man, which does not respect
;; SOURCE_DATE_EPOCH. We cannot just use the latest help2man,
;; because that breaks a test.
@@ -312,6 +317,17 @@ as.POSIXct(if (\"\" != Sys.getenv(\"SOURCE_DATE_EPOCH\")) {\
("perl" ,perl)
("pkg-config" ,pkg-config)
("texinfo" ,texinfo) ; for building HTML manuals
+ ("texlive" ,(texlive-union (list texlive-fonts-amsfonts
+ texlive-fonts-ec
+ texlive-latex-amsfonts
+ texlive-latex-base
+ texlive-latex-fancyvrb
+ texlive-latex-graphics
+ texlive-latex-hyperref
+ texlive-latex-oberdiek
+ texlive-latex-tools
+ texlive-latex-upquote
+ texlive-latex-url)))
("tzdata" ,tzdata-for-tests)
("xz" ,xz)))
(inputs