aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2019-04-26 18:21:18 +0200
committerJulien Lepiller <julien@lepiller.eu>2019-04-26 18:28:58 +0200
commit12c3f62ab202b5b3e1fa55f0df55fe5aa5c17747 (patch)
tree1f36e2c0d400c3e92228d7e9e7a7ac7ede4ee83c
parent7e49538483add98ebf1bcf85be52cadfa492737e (diff)
downloadguix-12c3f62ab202b5b3e1fa55f0df55fe5aa5c17747.tar
guix-12c3f62ab202b5b3e1fa55f0df55fe5aa5c17747.tar.gz
gnu: ocaml-easy-format: Update to 1.3.1.
* gnu/packages/ocaml.scm (ocaml-easy-format): Update to 1.3.1. [build-system]: Use dune-build-system. [source]: Use git-fetch.
-rw-r--r--gnu/packages/ocaml.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 379dd624c6..2114a59d7d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -2694,20 +2694,19 @@ JSON.")
(define-public ocaml-easy-format
(package
(name "ocaml-easy-format")
- (version "1.2.0")
+ (version "1.3.1")
(source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/mjambon/easy-format/"
- "archive/v" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/mjambon/easy-format")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "1zcz682y9figa84k7lgdjcab5qbzk3yy14ygfqp2dhhrvjygm252"))
- (file-name (string-append name "-" version ".tar.gz"))))
- (build-system ocaml-build-system)
+ "0jfncci15b8sf1y72yrxfjlsmhs9aavcd14vwz4d7kj8k9w9c4qk"))))
+ (build-system dune-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- (delete 'configure))))
+ `(#:jbuild? #t))
(home-page "https://github.com/mjambon/easy-format")
(synopsis "Interface to the Format module")
(description "Easy-format is a high-level and functional interface to the