aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-26 00:58:06 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-26 00:58:06 +0200
commit03c443ce8f472a6a27d939b1106404c9245f9a12 (patch)
tree88e1c46adc20f152c80acfe3214169088483fc51
parent55036ddc9a096c2bdf573b8cffb2605ecc7e30f9 (diff)
downloadguix-03c443ce8f472a6a27d939b1106404c9245f9a12.tar
guix-03c443ce8f472a6a27d939b1106404c9245f9a12.tar.gz
gnu: hcxtools: Update to 5.1.4.
* gnu/packages/networking.scm (hcxtools): Update to 5.1.4.
-rw-r--r--gnu/packages/networking.scm80
1 files changed, 38 insertions, 42 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 665b5df937..329b97c3d4 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -2201,51 +2201,47 @@ Ethernet and TAP interfaces is supported. Packet capture is also supported.")
(license license:gpl3+)))
(define-public hcxtools
- (let* ((commit "2ecfc9a06c2028c47522ea566ccd82b2c1f94647"))
- (package
- (name "hcxtools")
- (version (git-version "0.0.0" "1" commit))
- (home-page "https://github.com/ZerBea/hcxtools")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url home-page)
- (commit commit)))
- (sha256
- (base32
- "1hzwrpmxjxl674if0pp5iq06mdi24k7ni7bh1h20isp4s40201n3"))
- (file-name (git-file-name name version))))
- (build-system gnu-build-system)
- (inputs
- `(("curl" ,curl)
- ("libpcap" ,libpcap)
- ("openssl" ,openssl)
- ("zlib" ,zlib)))
- (arguments
- `(#:make-flags (list "CC=gcc"
- (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
- #:tests? #f ;no tests
- #:phases
- (modify-phases %standard-phases
- (delete 'configure)
- (add-after 'unpack 'set-environment
- (lambda* (#:key inputs #:allow-other-keys)
- (setenv "C_INCLUDE_PATH"
- (string-append (assoc-ref inputs "curl")
- "/include:"
- (assoc-ref inputs "libpcap")
- "/include:"
- (assoc-ref inputs "openssl")
- "/include:"
- (assoc-ref inputs "zlib")
- "/include:"
+ (package
+ (name "hcxtools")
+ (version "5.1.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ZerBea/hcxtools.git")
+ (commit version)))
+ (sha256
+ (base32 "1bkl0j6m5q091fas99s83aclcc5kfwacmkgmyg8565z2npvnj7nf"))
+ (file-name (git-file-name name version))))
+ (build-system gnu-build-system)
+ (inputs
+ `(("curl" ,curl)
+ ("libpcap" ,libpcap)
+ ("openssl" ,openssl)
+ ("zlib" ,zlib)))
+ (arguments
+ `(#:make-flags
+ (list "CC=gcc"
+ (string-append "INSTALLDIR=" (assoc-ref %outputs "out") "/bin"))
+ #:tests? #f ; no test suite
+ #:phases
+ (modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'set-environment
+ (lambda* (#:key inputs #:allow-other-keys)
+ (setenv "C_INCLUDE_PATH"
+ (string-append (assoc-ref inputs "curl") "/include:"
+ (assoc-ref inputs "libpcap") "/include:"
+ (assoc-ref inputs "openssl") "/include:"
+ (assoc-ref inputs "zlib") "/include:"
(getenv "C_INCLUDE_PATH")))
#t)))))
- (synopsis "Capture wlan traffic to hashcat and John the Ripper")
- (description
- "This package contains a small set of tools to capture and convert
+ (home-page "https://github.com/ZerBea/hcxtools")
+ (synopsis "Capture wlan traffic to hashcat and John the Ripper")
+ (description
+ "This package contains a small set of tools to capture and convert
packets from wireless devices for use with hashcat or John the Ripper.")
- (license license:expat))))
+ (license license:expat)))
(define-public hcxdumptool
(let* ((commit "f4799b5da82c5b030a6d99b02d1c1b9dc838ad36"))