aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-05 00:02:37 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2022-11-05 00:24:08 +0100
commit0f8f9844a98229d061d532c38a604bbe200ed743 (patch)
tree4798e55128b24e6758f844a4abf09dbddc0d9cf6
parent3a227cff367e5b5415624adcb15eed124ac7768d (diff)
downloadguix-0f8f9844a98229d061d532c38a604bbe200ed743.tar
guix-0f8f9844a98229d061d532c38a604bbe200ed743.tar.gz
gnu: emacs-ts: Update to 0.3.
* gnu/packages/emacs-xyz.scm (emacs-ts): Update to 0.3. [arguments]: Use G-expressions. Remove traling #T. <#:phases>: Skip a slightly different set of tests. [propagated-inputs]: Re-order alphabetically.
-rw-r--r--gnu/packages/emacs-xyz.scm120
1 files changed, 61 insertions, 59 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 8478a47591..a75fb0ced3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19687,66 +19687,68 @@ tables of contents.")
(license license:gpl3+)))
(define-public emacs-ts
- (package
- (name "emacs-ts")
- (version "0.2.2")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/alphapapa/ts.el")
- (commit version)))
- (sha256
- (base32 "0l35gz1hpada2kzascbyqgawa5d3sdyg67gzvak84p9zx62jppn8"))
- (file-name (git-file-name name version))))
- (build-system emacs-build-system)
- (propagated-inputs
- (list emacs-s emacs-dash))
- (arguments
- ;; XXX: Three tests are failing because of a timezone-related issue
- ;; with how they're written. On my machine, all the failing test
- ;; results are 18000 seconds (5 hours) off.
-
- ;; The ts-parse-org function accepts a string without any timezone
- ;; info, not assumed to be in Unix time, and converts it to a so-called
- ;; ts struct. The ts-unix function (accessor) accepts a ts struct,
- ;; then seems to assume the struct's corresponding time is in terms of
- ;; the user's current time zone, before returning a Unix time in
- ;; seconds.
-
- ;; The failing tests all have similar problems, but nothing else about
- ;; the library seems particularly off.
-
- `(#:tests? #t
- #:test-command '("emacs" "--batch"
- "-l" "test/test.el"
- "-f" "ert-run-tests-batch-and-exit")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'make-tests-writable
- (lambda _
- (make-file-writable "test/test.el")
- #t))
- (add-before 'check 'delete-failing-tests
- (lambda _
- (emacs-batch-edit-file "test/test.el"
- `(progn (progn
- (goto-char (point-min))
- (dolist (test-regexp
- '("ert-deftest ts-format"
- "ert-deftest ts-parse-org\\_>"
- "ert-deftest ts-parse-org-element"
- "ert-deftest ts-update"))
- (re-search-forward test-regexp)
- (beginning-of-line)
- (kill-sexp)))
- (basic-save-buffer)))
- #t)))))
- (home-page "https://github.com/alphapapa/ts.el")
- (synopsis "Timestamp and date/time library")
- (description "This package facilitates manipulating dates, times, and
+ ;; XXX: Upstream did not tag last release. Use commit matching version
+ ;; bump.
+ (let ((commit "552936017cfdec89f7fc20c254ae6b37c3f22c5b"))
+ (package
+ (name "emacs-ts")
+ (version "0.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/alphapapa/ts.el")
+ (commit commit)))
+ (sha256
+ (base32 "18lif159zndl19ddz9rfq12l90770858yasfns21ryl1yrq3aifr"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ ;; XXX: Three tests are failing because of a timezone-related issue
+ ;; with how they're written. On my machine, all the failing test
+ ;; results are 18000 seconds (5 hours) off.
+
+ ;; The ts-parse-org function accepts a string without any timezone
+ ;; info, not assumed to be in Unix time, and converts it to a so-called
+ ;; ts struct. The ts-unix function (accessor) accepts a ts struct,
+ ;; then seems to assume the struct's corresponding time is in terms of
+ ;; the user's current time zone, before returning a Unix time in
+ ;; seconds.
+
+ ;; The failing tests all have similar problems, but nothing else about
+ ;; the library seems particularly off.
+ (list
+ #:tests? #t
+ #:test-command #~(list "emacs" "--batch"
+ "-l" "test/test.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'make-tests-writable
+ (lambda _
+ (make-file-writable "test/test.el")))
+ (add-before 'check 'delete-failing-tests
+ (lambda _
+ (emacs-batch-edit-file "test/test.el"
+ `(progn
+ (goto-char (point-min))
+ (dolist (test-regexp
+ '("ert-deftest ts-fill"
+ "ert-deftest ts-format"
+ "ert-deftest ts-parse-org\\_>"
+ "ert-deftest ts-parse-org-element"))
+ (re-search-forward test-regexp)
+ (beginning-of-line)
+ (kill-sexp)
+ (goto-char (point-min)))
+ (basic-save-buffer))))))))
+ (propagated-inputs
+ (list emacs-dash emacs-s))
+ (home-page "https://github.com/alphapapa/ts.el")
+ (synopsis "Timestamp and date/time library")
+ (description "This package facilitates manipulating dates, times, and
timestamps by providing a @code{ts} struct.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-circadian
(package