aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2022-06-19 22:42:00 +0200
committerRicardo Wurmus <rekado@elephly.net>2022-11-04 14:27:40 +0100
commit04f8295f6f91d8a5c75a212fc4b0a5174d89b996 (patch)
treecfc09e788e84124708529179469b1ed786369de3
parent49e1a3a04b7aac1a5046f243f1320fef93effcf7 (diff)
downloadguix-04f8295f6f91d8a5c75a212fc4b0a5174d89b996.tar
guix-04f8295f6f91d8a5c75a212fc4b0a5174d89b996.tar.gz
gnu: Add r-microbiome.
* gnu/packages/bioconductor.scm (r-microbiome): New variable.
-rw-r--r--gnu/packages/bioconductor.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index cb9feda347..f3b67fd2bf 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -9736,6 +9736,43 @@ to identify differentially methylated regions in epigenetic epidemiology
studies.")
(license license:artistic2.0)))
+(define-public r-microbiome
+ (package
+ (name "r-microbiome")
+ (version "1.18.0")
+ (source (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "microbiome" version))
+ (sha256
+ (base32
+ "1z9arkjp5xszlg07mzb4p163i74jfbd9p4gbwv5syivnpl040k12"))))
+ (properties `((upstream-name . "microbiome")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-biostrings
+ r-compositions
+ r-dplyr
+ r-ggplot2
+ r-phyloseq
+ r-reshape2
+ r-rtsne
+ r-scales
+ r-tibble
+ r-tidyr
+ r-vegan))
+ (native-inputs (list r-knitr))
+ (home-page "https://microbiome.github.io/microbiome/")
+ (synopsis "Tools for microbiome analysis")
+ (description
+ "This package facilitates phyloseq exploration and analysis of taxonomic
+profiling data. This package provides tools for the manipulation, statistical
+analysis, and visualization of taxonomic profiling data. In addition to
+targeted case-control studies, microbiome facilitates scalable exploration of
+population cohorts. This package supports the independent phyloseq data
+format and expands the available toolkit in order to facilitate the
+standardization of the analyses and the development of best practices.")
+ (license license:bsd-2)))
+
(define-public r-milor
(package
(name "r-milor")