aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Rohleder <mike@rohleder.de>2022-10-23 05:51:00 +0200
committerChristopher Baines <mail@cbaines.net>2022-11-05 11:28:42 +0100
commit02a53634806386cd6f0e0de3b2decb451c52225b (patch)
tree6527a91da2bd80949ed33e59490a9d1cc9bb1db9
parent6123f0e467aa5249f0a497c89ce434222702a535 (diff)
downloadguix-02a53634806386cd6f0e0de3b2decb451c52225b.tar
guix-02a53634806386cd6f0e0de3b2decb451c52225b.tar.gz
gnu: python-frozendict: Update to 2.3.4.
This fixes a potential memory leak with python 3.9: https://github.com/slezica/python-frozendict/issues/38 * gnu/packages/python-xyz.scm (python-frozendict): Update to 2.3.4. [home-page]: Set to new upstream repository. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 75e1dcc0cb..cd713c565e 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -79,7 +79,7 @@
;;; Copyright © 2020 Ryan Prior <rprior@protonmail.com>
;;; Copyright © 2020 Josh Holland <josh@inv.alid.pw>
;;; Copyright © 2020 Yuval Kogman <nothingmuch@woobling.org>
-;;; Copyright © 2020 Michael Rohleder <mike@rohleder.de>
+;;; Copyright © 2020, 2022 Michael Rohleder <mike@rohleder.de>
;;; Copyright © 2020, 2021, 2022 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Guy Fleury Iteriteka <gfleury@disroot.org>
;;; Copyright © 2020 Hendursaga <hendursaga@yahoo.com>
@@ -26068,15 +26068,15 @@ library. Only the high-level API is bound.")
(define-public python-frozendict
(package
(name "python-frozendict")
- (version "1.2")
+ (version "2.3.4")
(source
(origin
(method url-fetch)
(uri (pypi-uri "frozendict" version))
(sha256
- (base32 "0ibf1wipidz57giy53dh7mh68f2hz38x8f4wdq88mvxj5pr7jhbp"))))
+ (base32 "0y3zn57i1q5192f7l4w2z2zsy3rrx50g563msaq954r58s1v3d0m"))))
(build-system python-build-system)
- (home-page "https://github.com/slezica/python-frozendict")
+ (home-page "https://github.com/Marco-Sulla/python-frozendict")
(synopsis "Simple immutable mapping for Python")
(description
"@dfn{frozendict} is an immutable wrapper around dictionaries that