aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-07-15 12:13:34 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-15 12:18:01 +0200
commitd71d85cd17ea86d902f6d8109e43134138640a90 (patch)
tree1ffc74f1f71e1b2bcb4865f73e25a2efea4ff774
parent64ed7c22589634a118feb798c18188d84e5ba975 (diff)
downloadguix-d71d85cd17ea86d902f6d8109e43134138640a90.tar
guix-d71d85cd17ea86d902f6d8109e43134138640a90.tar.gz
gnu: Add python-progressbar33.
* gnu/packages/python-xyz.scm (python-progressbar33): New variable.
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3aff94e359..eda21d8c64 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8538,6 +8538,28 @@ concurrent.futures package from Python 3.2")
("python2-pytest" ,python2-pytest)
,@(package-native-inputs promise))))))
+(define-public python-progressbar33
+ (package
+ (name "python-progressbar33")
+ (version "2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "progressbar33" version))
+ (sha256
+ (base32
+ "1zvf6zs5hzrc03p9nfs4p16vhilqikycvv1yk0pxn8s07fdhvzji"))))
+ (build-system python-build-system)
+ (home-page "http://github.com/germangh/python-progressbar")
+ (synopsis "Text progress bar library for Python")
+ (description
+ "This package provides a text progress bar library for Python. This
+version only differs from the original @code{progressbar} package in that it
+uses relative package imports instead of absolute imports, which is necessary
+for the module to work under Python 3.3.")
+ ;; Either or both of these licenses may be selected.
+ (license (list license:lgpl2.1+ license:bsd-3))))
+
(define-public python-colorama
(package
(name "python-colorama")