aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGuillaume Le Vaillant <glv@posteo.net>2019-07-14 17:37:19 +0200
committerLudovic Courtès <ludo@gnu.org>2019-07-15 12:48:49 +0200
commitcb45aad9b06ebc2b8f8b9f8786007d746f7d2ee1 (patch)
treebce3e4696f1019dc705a4465cd9a6cbb80d1c1d9
parent886986b744f9bbf0d27c365a0e466a7f21d004f8 (diff)
downloadguix-cb45aad9b06ebc2b8f8b9f8786007d746f7d2ee1.tar
guix-cb45aad9b06ebc2b8f8b9f8786007d746f7d2ee1.tar.gz
gnu: monero: Make tests more verbose.
Increase the verbosity of the 'check' phase to prevent 'core_tests' from hitting 'max-silent-timeout'. * gnu/packages/finance.scm (monero)[arguments]: Add '--verbose' option to 'check' phase. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/finance.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 918ba006f2..977ac9c19c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -509,7 +509,7 @@ other machines/servers. Electroncash does not download the Bitcoin Cash blockch
;; Only try tests that don't need access to network or system
(replace 'check
(lambda _
- (invoke "make" "ARGS=-R 'hash|core_tests'" "test")))
+ (invoke "make" "ARGS=-R 'hash|core_tests' --verbose" "test")))
(add-after 'check 'unit-tests
(lambda _
(let ((excluded-unit-tests