aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPierre Langlois <pierre.langlois@gmx.com>2019-07-06 20:49:40 +0100
committerLudovic Courtès <ludo@gnu.org>2019-07-11 23:15:00 +0200
commitc894b80324d82f2f807578efa1de792ed1331eb3 (patch)
treef3e2ae719f4b176971cb866ed60e5fac5d8f64f4
parent3fb666bd40761a102dfb1e52b8ec34f104151c8a (diff)
downloadguix-c894b80324d82f2f807578efa1de792ed1331eb3.tar
guix-c894b80324d82f2f807578efa1de792ed1331eb3.tar.gz
gnu: sbcl-clx: Update to 0.7.5.
* gnu/packages/lisp.scm (sbcl-clx): Update to 0.7.5. [origin]: Drop "clx-remove-demo.patch" and the snippet that removes demo code. * gnu/packages/patches/clx-remove-demo.patch: Delete file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/lisp.scm56
-rw-r--r--gnu/packages/patches/clx-remove-demo.patch27
3 files changed, 22 insertions, 62 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 9a70d73759..ae5477c428 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -735,7 +735,6 @@ dist_patch_DATA = \
%D%/packages/patches/clementine-use-openssl.patch \
%D%/packages/patches/clisp-remove-failing-test.patch \
%D%/packages/patches/clucene-pkgconfig.patch \
- %D%/packages/patches/clx-remove-demo.patch \
%D%/packages/patches/coda-use-system-libs.patch \
%D%/packages/patches/combinatorial-blas-awpm.patch \
%D%/packages/patches/combinatorial-blas-io-fix.patch \
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 3aa2429595..884d00d935 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -11,7 +11,7 @@
;;; Copyright © 2018 Benjamin Slade <slade@jnanam.net>
;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
-;;; Copyright © 2018 Pierre Langlois <pierre.langlois@gmx.com>
+;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
;;; Copyright © 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright © 2019 Jesse Gildersleve <jessejohngildersleve@protonmail.com>
;;; Copyright © 2019 Guillaume Le Vaillant <glv@posteo.net>
@@ -930,42 +930,30 @@ ANSI-compliant Common Lisp implementations.")
(sbcl-package->cl-source-package sbcl-cl-unicode))
(define-public sbcl-clx
- (let ((revision "1")
- (commit "1c62774b03c1cf3fe6e5cb532df8b14b44c96b95"))
- (package
- (name "sbcl-clx")
- (version (string-append "0.0.0-" revision "." (string-take commit 7)))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/sharplispers/clx.git")
- (commit commit)))
- (sha256
- (base32 "0qffag03ns52kwq9xjns2qg1yr0bf3ba507iwq5cmx5xz0b0rmjm"))
- (file-name (string-append "clx-" version "-checkout"))
- (patches
- (list
- (search-patch "clx-remove-demo.patch")))
- (modules '((guix build utils)))
- (snippet
- '(begin
- ;; These removed files cause the compiled system to crash when
- ;; loading.
- (delete-file-recursively "demo")
- (delete-file "test/trapezoid.lisp")
- (substitute* "clx.asd"
- (("\\(:file \"trapezoid\"\\)") ""))
- #t))))
- (build-system asdf-build-system/sbcl)
- (home-page "http://www.cliki.net/portable-clx")
- (synopsis "X11 client library for Common Lisp")
- (description "CLX is an X11 client library for Common Lisp. The code was
+ (package
+ (name "sbcl-clx")
+ (version "0.7.5")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/sharplispers/clx.git")
+ (commit version)))
+ (sha256
+ (base32
+ "1vi67z9hpj5rr4xcmfbfwzmlcc0ah7hzhrmfid6lqdkva238v2wf"))
+ (file-name (string-append "clx-" version))))
+ (build-system asdf-build-system/sbcl)
+ (native-inputs
+ `(("fiasco" ,sbcl-fiasco)))
+ (home-page "http://www.cliki.net/portable-clx")
+ (synopsis "X11 client library for Common Lisp")
+ (description "CLX is an X11 client library for Common Lisp. The code was
originally taken from a CMUCL distribution, was modified somewhat in order to
make it compile and run under SBCL, then a selection of patches were added
from other CLXes around the net.")
- (license license:x11))))
+ (license license:x11)))
(define-public cl-clx
(sbcl-package->cl-source-package sbcl-clx))
diff --git a/gnu/packages/patches/clx-remove-demo.patch b/gnu/packages/patches/clx-remove-demo.patch
deleted file mode 100644
index c5fffea0d0..0000000000
--- a/gnu/packages/patches/clx-remove-demo.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/clx.asd 2016-02-16 00:06:48.161596976 -0500
-+++ b/clx.asd 2016-02-16 00:06:54.793774658 -0500
-@@ -79,24 +79,6 @@
- (:file "xtest")
- (:file "screensaver")
- (:file "xinerama")))
-- (:module demo
-- :default-component-class example-source-file
-- :components
-- ((:file "bezier")
-- ;; KLUDGE: this requires "bezier" for proper operation,
-- ;; but we don't declare that dependency here, because
-- ;; asdf doesn't load example files anyway.
-- (:file "beziertest")
-- (:file "clclock")
-- (:file "clipboard")
-- (:file "clx-demos")
-- (:file "gl-test")
-- ;; FIXME: compiling this generates 30-odd spurious code
-- ;; deletion notes. Find out why, and either fix or
-- ;; workaround the problem.
-- (:file "mandel")
-- (:file "menu")
-- (:file "zoid")))
- (:module test
- :default-component-class example-source-file
- :components