aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2019-07-07 18:54:29 +0100
committerChristopher Baines <mail@cbaines.net>2019-07-13 23:18:54 +0100
commitbee9f97e0ae55c1d4c7e35ddd1c31be24ff32e23 (patch)
tree0ecf1fb865ec22386f077c68a6fad9aa9033bb6c
parent29fe71152f26e2e4cd9a6be89fd45109b2775743 (diff)
downloadguix-bee9f97e0ae55c1d4c7e35ddd1c31be24ff32e23.tar
guix-bee9f97e0ae55c1d4c7e35ddd1c31be24ff32e23.tar.gz
gnu: Add s-tui.
* gnu/packages/admin.scm (s-tui): New variable.
-rw-r--r--gnu/packages/admin.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1c49e4565e..3ce39b03e6 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1453,6 +1453,28 @@ tables. This package contains only the user-space tools needed for ACPI table
development, not the kernel implementation of ACPI.")
(license license:gpl2))) ; dual GPLv2/ACPICA Licence
+(define-public s-tui
+ (package
+ (name "s-tui")
+ (version "0.8.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "s-tui" version))
+ (sha256
+ (base32
+ "00lsh2v4i8rwfyjyxx5lijd6rnk9smcfffhzg5sv94ijpcnh216m"))))
+ (build-system python-build-system)
+ (inputs
+ `(("python-psutil" ,python-psutil)
+ ("python-urwid" ,python-urwid)))
+ (home-page "https://github.com/amanusk/s-tui")
+ (synopsis "Interactive terminal stress test and monitoring tool")
+ (description
+ "The Stress Terminal UI displays graphs of the CPU frequency,
+utilization, temperature and power.")
+ (license license:gpl2+)))
+
(define-public stress
(package
(name "stress")