aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-15 17:20:24 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-15 20:38:00 +0200
commit6e00b1ea62584b55d6019fd81943aebba853729a (patch)
tree732090f16a3ec906b539bd79d8381fa19a63e8e8
parent9db2cad68d3f041f61bfb916f7e4292276a8d860 (diff)
downloadguix-6e00b1ea62584b55d6019fd81943aebba853729a.tar
guix-6e00b1ea62584b55d6019fd81943aebba853729a.tar.gz
gnu: python-cachecontrol: Do not use unstable source archive.
* gnu/packages/python-web.scm (python-cachecontrol)[source]: Change to GIT-FETCH.
-rw-r--r--gnu/packages/python-web.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index 7047c515e2..d1ca5a1947 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -1982,15 +1982,15 @@ provide an easy-to-use Python interface for building OAuth1 and OAuth2 clients."
(version "0.11.6")
(source
(origin
- (method url-fetch)
+ (method git-fetch)
;; Pypi does not have tests.
- (uri (string-append
- "https://github.com/ionrock/cachecontrol/archive/v"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (git-reference
+ (url "https://github.com/ionrock/cachecontrol")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0yj60d0f69a2l8p7y86k4zhzzm6rnxpq74sfl240pry9l0lfw2vw"))))
+ "0pb16bzbkk99nh317xyfk8fxc2ngimsbz7lz9pxsw8c82n83d4dh"))))
(build-system python-build-system)
(arguments
`(#:phases