aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOleg Pykhalov <go.wigust@gmail.com>2019-07-12 23:45:21 +0300
committerOleg Pykhalov <go.wigust@gmail.com>2019-07-13 00:22:52 +0300
commit5516a75b0b5c19f25b8fec3a647608ae44c1adf2 (patch)
tree74644304c9c4c019d6e67e122ebee16a70e35270
parentdd9c137b2c759f906d57b14fccff091994f274e8 (diff)
downloadguix-5516a75b0b5c19f25b8fec3a647608ae44c1adf2.tar
guix-5516a75b0b5c19f25b8fec3a647608ae44c1adf2.tar.gz
gnu: Add emacs-matcha.
* gnu/packages/emacs-xyz.scm (emacs-matcha): New variable.
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 2d9f271cc8..fb305dda0c 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -15340,6 +15340,30 @@ command\", but because it always involves at least two commands (a prefix and
a suffix) we prefer to call it just a \"transient\".")
(license license:gpl3+))))
+(define-public emacs-matcha
+ (let ((commit "c7df5cf5cdac9ae369e241342389ccda0205eab9"))
+ (package
+ (name "emacs-matcha")
+ (version (git-version "0.0.1" "1" commit)) ;no upstream release
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jojojames/matcha.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lfnh1glg6al677m7ci0x8g5wjdhjxlfl3nv1f1ppsw4dpnwsj9b"))))
+ (propagated-inputs
+ `(("emacs-hydra" ,emacs-hydra)
+ ("emacs-transient" ,emacs-transient)))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/jojojames/matcha/")
+ (synopsis "Collection of hydras with a generic interface to launch them")
+ (description "Matcha provides a collection of transients for various
+packages with a consistent way to use them.")
+ (license license:gpl3+))))
+
(define-public emacs-undo-propose-el
(let ((commit "5f1fa99a04369a959aad01b476fe4f34229f28cd")
(version "1.0.0")